Составить программу вычисления количества элементов массива s[4] [4], которые больше заданного
числа М ( М ввести с клавиатуры). Есть пример с одномерным #include using namespace std; int main(int argc, char *argv[]) { int N,i,j,L; cout << "Vvedi kol-vo elementov: "; cin >> N; int a[N]; for(i=0;i > a[i]; } cout << "Vvedi L: "; cin >> L; for(i=0;i L) a[i] = 5; } for(i=0;i { cout << "a[" << i << "]=" << a[i] << endl; } }Ответы на вопрос
Відповідь:
#include <iostream>
#include <cstdlib>
#include <time.h>
using namespace std;
void randarr(int **arr,const int n,const int m){
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++){
arr[i][j] = rand() % 100 + 1;
}
}
}
void printarr(int **arr,const int n,const int m){
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++){
cout << arr[i][j] << "\t";
}
cout << endl;
}
}
int expression(int **arr,const int n,const int m,int M){
int counter = 0;
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++){
if(arr[i][j] > M){
counter++;
}
}
}
return counter;
}
const int n = 4, m = 4;
int main(){
srand(time(NULL));
setlocale(LC_ALL , "Rus");
int M;
cout << "Введите число M: ";
cin >> M;
int **arr = new int *[n];
for (int i = 0; i < n; i++)
arr[i]=new int[m];
cout << "\nМассив: " << endl;
randarr(arr,n,m);
printarr(arr,n,m);
cout << "\nЕлементов массива которые больше чем " << M << " = " << expression(arr,n,m,M) << endl;
for (int i = 0; i < n; i++)
delete[]arr[i];
delete[]arr;
return 0;
}
Для вычисления количества элементов в двумерном массиве s[4][4], которые больше заданного числа M, вы можете использовать следующую программу на C++:
cpp#include <iostream>
using namespace std;
int main() {
int s[4][4];
int M;
int count = 0;
// Ввод элементов массива s[4][4] с клавиатуры
for (int i = 0; i < 4; i++) {
for (int j = 0; j < 4; j++) {
cout << "Введите элемент s[" << i << "][" << j << "]: ";
cin >> s[i][j];
}
}
// Ввод значения M с клавиатуры
cout << "Введите число M: ";
cin >> M;
// Подсчет элементов больше M
for (int i = 0; i < 4; i++) {
for (int j = 0; j < 4; j++) {
if (s[i][j] > M) {
count++;
}
}
}
cout << "Количество элементов в массиве, больших чем " << M << ": " << count << endl;
return 0;
}
Эта программа сначала запрашивает у пользователя ввод элементов для двумерного массива s[4][4]. Затем она запрашивает значение M. После этого программа перебирает все элементы массива и подсчитывает количество элементов, которые больше M. Результат выводится на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
