Вопрос задан 26.09.2023 в 02:53. Предмет Информатика. Спрашивает Новожилова Аполлинария.

65 баллов. Срочно! задача на python Необходимо написать программу, которая будет принимать на свой

вход слова до тех пор, пока их суммарное количество букв не станет больше 100, далее программа должна выводить на экран общее количество введенных слов, а также самое длинное слово, которое было введено. Только объясните потом, как отдать баллы, я первый раз здесь.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Гнатовский Николай.

Ответ:

n=input()

sum=len(n)

maxStr=n

maxLen=sum

while sum<=100:

   n=input()

   if len(n)>maxLen:

       maxLen=len(n)

       maxStr=n

   sum+=len(n)

print(maxLen)

print(maxStr)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Я помогу вам с этой задачей на Python. Вот код:

python
def main(): total_length = 0 longest_word = "" word_count = 0 while total_length <= 100: word = input("Введите слово: ") total_length += len(word) if len(word) > len(longest_word): longest_word = word word_count += 1 print(f"Общее количество введенных слов: {word_count}") print(f"Самое длинное слово: {longest_word}") if __name__ == "__main__": main()

Эта программа запрашивает у пользователя ввод слов до тех пор, пока общая длина введенных слов не достигнет или превысит 100 символов. Затем она выводит общее количество введенных слов и самое длинное слово.

Чтобы отдать баллы, выполните следующие шаги:

  1. Скопируйте этот код в вашу среду разработки Python.
  2. Запустите программу.
  3. Введите слова, пока не будет достигнуто условие (введено более 100 символов).
  4. После завершения программы оцените ее работу.

Если у вас есть какие-то вопросы или что-то неясно, не стесняйтесь спрашивать!

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос