Вопрос задан 25.09.2023 в 21:36. Предмет Информатика. Спрашивает Варежкин Антон.

Ваша задача — написать программу, которая перемножает все цифры, введенного пользователем целого

числа, пока оно не станет меньше либо равной 9. Число вводит пользователь с клавиатуры, и оно всегда должно быть больше нуля. Примеры: 999 -> 2 # 999 -> 9 * 9 * 9 = 729 -> 7 * 2 * 9 = 126 -> 1 * 2 * 6 = 12 -> 1 * 2 = 2 1000 -> 0 423 -> 8 1 -> 1 Надо решить без использования функций
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Нерода Арина.

Ответ:

print("Введите целое число")

n = int(input());

i = 0

multiple = 1

string = str(n)

do = len(string)

while i < do:

   multiple = multiple * (n % 10)

   n = int(((n - n % 10) / 10))

   i += 1

   if (i == do):

       if (multiple > 9):

           n = multiple

           multiple = 1

           i = 0

           string = str(n)

           do = len(string)

       else:

           break

print("результат: ",multiple)

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи можно написать программу на Python, которая будет перемножать цифры введенного числа, пока оно не станет меньше либо равным 9. Вот код для такой программы:

python
# Просим пользователя ввести целое число больше 0 num = int(input("Введите целое число (больше 0): ")) # Пока число больше 9, продолжаем перемножать его цифры while num > 9: product = 1 # Разбиваем число на цифры и перемножаем их while num > 0: digit = num % 10 product *= digit num //= 10 num = product # Выводим результат print("Результат:", num)

Этот код сначала запрашивает у пользователя ввод целого числа, затем внутри цикла while перемножает его цифры, пока число больше 9, и назначает результат обратно переменной num. Как только num становится меньше или равным 9, программа завершает выполнение и выводит результат.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос