Составьте программу расположения элементов в массиве А (N) в порядке возрастания. на языке С
Ответы на вопрос
#include <stdio.h>
int main()
{
int N, i, j, temp;
printf("Введите размер массива: ");
scanf("%d", &N);
int A[N];
printf("\nВведите элементы массива: \n");
for (i = 0; i < N; ++i) {
scanf("%d", &A[i]);
}
for (i = 0; i < N; ++i) {
for (j = i + 1; j < N; ++j) {
if (A[i] > A[j]) {
temp = A[i];
A[i] = A[j];
A[j] = temp;
}
}
}
printf("\nМассив в порядке возрастания: \n");
for (i = 0; i < N; ++i) {
printf("%d\t", A[i]);
}
return 0;
}
Для сортировки элементов в массиве A(N) в порядке возрастания можно использовать алгоритм сортировки пузырьком. Вот пример программы на языке C:
c#include <stdio.h>
void bubbleSort(int arr[], int n) {
int temp;
int swapped;
do {
swapped = 0;
for (int i = 1; i < n; i++) {
if (arr[i - 1] > arr[i]) {
// Обмен элементов местами
temp = arr[i - 1];
arr[i - 1] = arr[i];
arr[i] = temp;
swapped = 1;
}
}
} while (swapped);
}
int main() {
int N;
printf("Введите размер массива: ");
scanf("%d", &N);
int A[N];
printf("Введите элементы массива:\n");
for (int i = 0; i < N; i++) {
scanf("%d", &A[i]);
}
// Сортировка массива
bubbleSort(A, N);
printf("Массив в порядке возрастания:\n");
for (int i = 0; i < N; i++) {
printf("%d ", A[i]);
}
return 0;
}
Эта программа сначала запрашивает размер массива и его элементы от пользователя, а затем сортирует массив с использованием сортировки пузырьком. Результат будет выведен в порядке возрастания.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
