
Напишите программу, которая запрашивает пять целых чисел (от -10000 до 10000) и выстраивает их по
невозрастанию. Язык С++ 5-ые классы

Ответы на вопрос

Ответ:
#include <iostream>
#include <algorithm>
int main() {
int numbers[5];
std::cout << "Введите пять целых чисел: " << std::endl;
// Запрашиваем числа от пользователя
for (int i = 0; i < 5; ++i) {
std::cin >> numbers[i];
}
// Сортируем числа по невозрастанию
std::sort(numbers, numbers + 5, std::greater<int>());
// Выводим отсортированные числа
std::cout << "Числа в порядке невозрастания: ";
for (int i = 0; i < 5; ++i) {
std::cout << numbers[i] << " ";
}
std::cout << std::endl;
return 0;
}



Конечно, вот простая программа на C++, которая попросит пользователя ввести пять целых чисел и затем выведет их в порядке невозрастания:
cpp#include <iostream>
using namespace std;
int main() {
int numbers[5];
// Вводим пять целых чисел
cout << "Введите пять целых чисел:" << endl;
for (int i = 0; i < 5; i++) {
cin >> numbers[i];
}
// Сортируем числа в порядке невозрастания (пузырьковая сортировка)
for (int i = 0; i < 4; i++) {
for (int j = 0; j < 4 - i; j++) {
if (numbers[j] < numbers[j + 1]) {
// Обмен значениями
int temp = numbers[j];
numbers[j] = numbers[j + 1];
numbers[j + 1] = temp;
}
}
}
// Выводим отсортированные числа
cout << "Числа в порядке невозрастания:" << endl;
for (int i = 0; i < 5; i++) {
cout << numbers[i] << " ";
}
return 0;
}
Просто скопируйте этот код в среду разработки C++ (например, Code::Blocks или Visual Studio), скомпилируйте и запустите программу, чтобы ввести числа и увидеть результат.


Похожие вопросы
Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili