Вопрос задан 14.09.2023 в 12:26.
Предмет Информатика.
Спрашивает Цыганова Лариса.
Даны три числа АВС. Составьте программу, которая упорядочит их по возрастанию?
Ответы на вопрос
Отвечает Бельчич Лиана.
Var
a,b,c,max,min,mid:real;
begin
readln(a,b,c);
if (a>b) then begin max:=a; mid:=b end
else begin max:=b; mid:=a end;
if c>max then max:=c
else
if c>mid then begin min:=mid; mid:=c end;
write(min,' ',mid,' ',max);
end.
a,b,c,max,min,mid:real;
begin
readln(a,b,c);
if (a>b) then begin max:=a; mid:=b end
else begin max:=b; mid:=a end;
if c>max then max:=c
else
if c>mid then begin min:=mid; mid:=c end;
write(min,' ',mid,' ',max);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вы можете написать программу на различных языках программирования для упорядочивания трех чисел по возрастанию. Вот пример на языке Python:
python# Ввод трех чисел от пользователя
a = float(input("Введите число A: "))
b = float(input("Введите число B: "))
c = float(input("Введите число C: "))
# Создаем список из трех чисел
numbers = [a, b, c]
# Сортируем список по возрастанию
numbers.sort()
# Выводим отсортированные числа
print("Числа по возрастанию:", numbers)
Этот код позволяет пользователю ввести три числа, затем он создает список из этих чисел и сортирует его по возрастанию с помощью метода sort(). Отсортированные числа выводятся на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
