Вопрос задан 14.09.2023 в 07:06. Предмет Информатика. Спрашивает Балашова Женя.

Напишите программу в Паскале по условию Даны действительные числа x,y. Если х,у отрицательны, то

каждое значение заменить его модулем; если отрицательное только одно из них, то оба значения увеличить на 27; если оба значения не отрицательны, то оба значения уменьшить на 20.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Быков Виктор.
Var x,y:real;
begin
read (x,y);
if (x<0) and (y<0) then writeln (abs(x),' ',abs(y)) else
if ((x<0) and (y>=0)) or ((y<0) and (x>=0)) then writeln (x+27,' ',y+27) else
if (x>=0)and (y>=0) then writeln (x-20,' ',y-20);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на Pascal, которая выполняет заданные условия:

pascal
program ModifyNumbers; var x, y: real; begin // Вводим значения x и y writeln('Введите значение x:'); readln(x); writeln('Введите значение y:'); readln(y); // Проверяем условия и выполняем соответствующие действия if (x < 0) and (y < 0) then begin x := abs(x); y := abs(y); end else if (x < 0) or (y < 0) then begin x := x + 27; y := y + 27; end else begin x := x - 20; y := y - 20; end; // Выводим результат writeln('Измененные значения x и y:'); writeln('x = ', x); writeln('y = ', y); readln; end.

Эта программа сначала запрашивает у пользователя значения x и y, а затем проверяет условия и выполняет соответствующие операции. Результаты выводятся на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос