Вопрос задан 08.09.2023 в 00:51.
Предмет Информатика.
Спрашивает Козлов Роман.
Написать алгоритм для паскаля. Составить программу, которая после введённого с клавиатуры числа
от 1 до 99 обозначает денежную единицу дописывающую слово "копейка" в правильной форме.Ответы на вопрос
Отвечает Богданець Альонка.
//Составить программу, которая после введённого с клавиатуры числа от 1 до 99 обозначает денежную единицу дописывающую слово "копейка" в правильной форме.
begin
var a := ReadInteger;
var c : string;
Assert(a >= 1);
Assert(a <= 99);
case a of
1, 21, 31, 41, 51, 61, 71, 81, 91: c := 'Копейка';
2..4, 22..24, 32..34, 42..44, 52..54, 62..64, 72..74, 82..84, 92..94: c := 'Копейки';
5..20, 25..30, 35..40, 45..50, 55..60, 65..70, 75..80, 85..90, 95..100: c := 'Копеек';
end;
Writeln(a, ' ', c);
end.
begin
var a := ReadInteger;
var c : string;
Assert(a >= 1);
Assert(a <= 99);
case a of
1, 21, 31, 41, 51, 61, 71, 81, 91: c := 'Копейка';
2..4, 22..24, 32..34, 42..44, 52..54, 62..64, 72..74, 82..84, 92..94: c := 'Копейки';
5..20, 25..30, 35..40, 45..50, 55..60, 65..70, 75..80, 85..90, 95..100: c := 'Копеек';
end;
Writeln(a, ' ', c);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для написания программы на языке Pascal, которая будет добавлять правильное слово "копейка" к введенному числу от 1 до 99, вы можете использовать следующий алгоритм:
pascalprogram AddKopeyka; var amount: integer; kopeykaWord: string; begin writeln('Введите число от 1 до 99: '); readln(amount); if (amount < 1) or (amount > 99) then writeln('Число должно быть от 1 до 99') else begin if (amount mod 10 = 1) and (amount <> 11) then kopeykaWord := 'копейка' else if (amount mod 10 >= 2) and (amount mod 10 <= 4) and ((amount < 10) or (amount > 20)) then kopeykaWord := 'копейки' else kopeykaWord := 'копеек'; writeln('Вы ввели ', amount, ' ', kopeykaWord); end; end.
Этот код сначала запрашивает число от пользователя, затем проверяет, находится ли число в диапазоне от 1 до 99. Если число в этом диапазоне, программа определяет правильное склонение слова "копейка" и выводит результат на экран.
Пожалуйста, убедитесь, что ваша среда разработки поддерживает Pascal, и скопируйте этот код в ваш проект для выполнения.
Похожие вопросы
Информатика 82
Информатика 99
Информатика 13
Информатика 64
Информатика 31
Информатика 22
Информатика 39
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
