Вопрос задан 07.09.2023 в 02:37.
Предмет Информатика.
Спрашивает Баландин Никита.
Напишите программу в turbo pascal: найти корни квадратного уравнения ax^2+bx+c
Ответы на вопрос
Отвечает Феоктистова Виктория.
Var a,b,c,d,x,x1,x2:real;
begin
readln(a.b.c);
d:=sqr(b) - 4*a*c;
if d<0 then
write('нет корней')
else
If d=0 then begin
x:=-b/(2*a);
write(x); end
else begin
x1:=(-b+sqrt(d)/(2*a);
x2:=(-b-sqrt(d))/(2*a);
write(x1,x2);end;
readln
end.
begin
readln(a.b.c);
d:=sqr(b) - 4*a*c;
if d<0 then
write('нет корней')
else
If d=0 then begin
x:=-b/(2*a);
write(x); end
else begin
x1:=(-b+sqrt(d)/(2*a);
x2:=(-b-sqrt(d))/(2*a);
write(x1,x2);end;
readln
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для нахождения корней квадратного уравнения в Turbo Pascal, вы можете использовать следующий код:
pascalprogram QuadraticEquationSolver; var a, b, c, D, x1, x2: real; begin writeln('Введите коэффициенты квадратного уравнения:'); write('a = '); readln(a); write('b = '); readln(b); write('c = '); readln(c); D := b * b - 4 * a * c; // Дискриминант if D > 0 then begin x1 := (-b + sqrt(D)) / (2 * a); x2 := (-b - sqrt(D)) / (2 * a); writeln('Два действительных корня:'); writeln('x1 = ', x1:0:2); writeln('x2 = ', x2:0:2); end else if D = 0 then begin x1 := -b / (2 * a); writeln('Один действительный корень:'); writeln('x1 = ', x1:0:2); end else begin writeln('Нет действительных корней.'); end; readln; end.
Просто скопируйте этот код в вашу среду разработки Turbo Pascal и запустите программу. Она попросит вас ввести коэффициенты a, b и c, а затем выдаст корни квадратного уравнения или сообщение о их отсутствии.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
