Вопрос задан 06.09.2023 в 22:18.
Предмет Информатика.
Спрашивает Невская Александра.
СРОЧНО!Составить программу(10класс): дано предложение,заменить в нем все запятые на точки и
удалить из предложения подстрочку по запросу пользователя.Ответы на вопрос
Отвечает Горбунова Александра.
uses Crt;
var Stroka, PodStroka: string;
poz, i: integer;
begin
ClrScr;
Write(' Stroka : '); ReadLn (Stroka);
for i:= 1 to length (Stroka) do
if Stroka[i]=',' then Stroka[i]:='.';
WriteLn(' Zamena : ', Stroka);
WriteLn;
Write(' PosStroka : '); ReadLn (PodStroka);
poz:=Pos(PodStroka, Stroka);
Delete (Stroka,poz,length(PodStroka));
WriteLn(' Udalili : ', Stroka);
ReadLn;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на Python, которая выполняет указанные действия:
python# Введите исходное предложение
исходное_предложение = input("Введите исходное предложение: ")
# Заменяем запятые на точки
предложение_с_точками = исходное_предложение.replace(",", ".")
# Запрос пользователя для удаления подстроки
подстрока_удалить = input("Введите подстроку для удаления: ")
# Удаляем подстроку из предложения
окончательное_предложение = предложение_с_точками.replace(подстрока_удалить, "")
# Выводим окончательное предложение
print("Исходное предложение с заменой запятых на точки и удалением подстроки:")
print(окончательное_предложение)
Программа сначала просит вас ввести исходное предложение, затем она заменяет все запятые на точки и удаляет подстроку, которую вы указываете. На выходе будет измененное предложение.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
