 
Вопрос задан 05.09.2023 в 13:13.
Предмет Информатика.
Спрашивает Федів Антон.
КТО РЕШИТ , ТОМУ 70 БАЛЛОВ!! составить программу нахождения суммы чисел , кратных 3 в массиве М
[1:12] (числа вводятся с клавиатуры) 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Деревянкина Юля.
                
                   Program enot_peredelani;              
Var a: array[1..100] of integer;
c,d:integer;
begin
d:=0;
writeln('введите элемент массива');
for c:= 1 to 12 do
begin
readln(a[c]);
if a[c] mod 3 = 0 then
d:=a[c]+d;
end;
writeln('сумма чисел кратных 3 ==> ',d);
end.
                                        Var a: array[1..100] of integer;
c,d:integer;
begin
d:=0;
writeln('введите элемент массива');
for c:= 1 to 12 do
begin
readln(a[c]);
if a[c] mod 3 = 0 then
d:=a[c]+d;
end;
writeln('сумма чисел кратных 3 ==> ',d);
end.
 0
                    0
                     0
                    0
                 
        Отвечает Трунтаева Дарья.
                
                   Const              
n=12;
var
M:array[1..n] of integer;
i,s:integer;
begin
Writeln('Введите ',n,' элементов массива');
s:=0;
for i := 1 to n do
begin Read(M[i]); if M[i] mod 3=0 then s:=s+M[i] end;
Writeln('Сумма элементов, кратных трем, равна ',s)
end.
              
Тестовое решение:
Введите 12 элементов массива
32 18 40 52 8 14 28 35 18 21 11 41
Сумма элементов, кратных трем, равна 57
              
              
                                        n=12;
var
M:array[1..n] of integer;
i,s:integer;
begin
Writeln('Введите ',n,' элементов массива');
s:=0;
for i := 1 to n do
begin Read(M[i]); if M[i] mod 3=0 then s:=s+M[i] end;
Writeln('Сумма элементов, кратных трем, равна ',s)
end.
Тестовое решение:
Введите 12 элементов массива
32 18 40 52 8 14 28 35 18 21 11 41
Сумма элементов, кратных трем, равна 57
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Для создания программы нахождения суммы чисел, кратных 3, в массиве M [1:12], вы можете использовать язык программирования Python. Вот пример такой программы:
python# Создаем пустой массив M
M = []
# Заполняем массив M с клавиатуры
for i in range(1, 13):
    num = int(input(f"Введите число {i}: "))
    M.append(num)
# Инициализируем переменную для суммы чисел, кратных 3
sum_of_multiples_of_3 = 0
# Вычисляем сумму чисел, кратных 3, в массиве M
for num in M:
    if num % 3 == 0:
        sum_of_multiples_of_3 += num
# Выводим результат
print(f"Сумма чисел, кратных 3, в массиве M: {sum_of_multiples_of_3}")
Вы можете скопировать этот код в среду разработки Python и выполнить его. Программа попросит вас ввести 12 чисел, затем выведет сумму чисел, кратных 3, введенных вами чисел.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			