Вопрос задан 30.08.2023 в 09:25.
Предмет Информатика.
Спрашивает Жигалов Федя.
Напишите программу на Pascal ABC,которая читает массу 12 грузов,что загружаются в машину,и выдает
общую массу груза в машине после загрузки.Ответы на вопрос
Отвечает Левченко Софія.
// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
Writeln(ReadArrInteger(12).Sum)
end.
Тестовое решение:
50 38 12 73 27 14 53 48 31 27 14 18
405
begin
Writeln(ReadArrInteger(12).Sum)
end.
Тестовое решение:
50 38 12 73 27 14 53 48 31 27 14 18
405
Отвечает Михалев Иван.
Uses crt;var a,b,c,d,g,i,k,l,z,x,m,n,q:real;beginwriteln('введите число тон');readln(a);writeln('введите число ');readln(b);writeln('введите число ');readln(c);writeln('введите число ');readln(d);writeln('введите число ');readln(g);writeln('введите число ');readln(i);writeln('введите число ');readln(k);writeln('введите число ');readln(l);writeln('введите число ');readln(n);writeln('введите число ');readln(m);writeln('введите число ');readln(z);writeln('введите число ');readln(x);q:=a+b+c+d+g+i+k+l+z+x+m+n;writeln('Обща маса',q:10:2);end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на Pascal ABC, которая считывает массу 12 грузов и вычисляет общую массу груза в машине после загрузки:
pascalprogram CalculateTotalCargoWeight; var CargoWeights: array[1..12] of real; TotalWeight: real; i: integer; begin TotalWeight := 0; writeln('Введите массу 12 грузов:'); for i := 1 to 12 do begin write('Груз ', i, ': '); readln(CargoWeights[i]); TotalWeight := TotalWeight + CargoWeights[i]; end; writeln('Общая масса груза в машине: ', TotalWeight:0:2); end.
Эта программа создает массив CargoWeights для хранения масс каждого из 12 грузов, а затем использует цикл для считывания масс грузов и вычисления общей массы TotalWeight. Результат выводится на экран. Вы можете ввести массу каждого груза после запуска программы.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
