Вопрос задан 25.08.2023 в 01:37.
Предмет Информатика.
Спрашивает Себежко Дмитрий.
Помогите пожалуйста с заданием 1. В программе используется следующий массив под общим именем А:
Индексы элементов 1 2 3 4 5 Значения элементов 9 8 7 6 5 a) Опишите этот массив, используя образец VAR имя_массива: ARRAY [N1..N2] OF базовый тип; b) Выпишите в тетрадь равенства, подставляя вместо многоточия нужные числа: а[2]= …, а[3]=…, а[…]=6. 2. Напишите последовательность команд для обмена значениями b[11] и b[14]. 3. Напишите программу, которая находит сумму всех элементов массива. 4. Напишите программу, печатающую отрицательные элементы массива. 5. Отрицательные элементы массива возвести в квадрат, положительные – в третью степень.Ответы на вопрос
Отвечает Мамчиц Илона.
1. a) var a: array[1..5] of integer
b) а[2]=8, а[3]=7, а[4]=6.
2. c:=b[11]; b[11]:=b[14]; b[14]:=c;
3.
var
a: array[1..10] of integer;
s,i: integer;
begin
s:=0;
for i:=1 to 10 do begin
read (a[i]);
s:=s+a[i];
end;
writeln (s);
end.
4.
var
a: array[1..10] of integer;
i: integer;
begin
for i:=1 to 10 do begin
read (a[i]);
if a[i]<0 then
writeln (a[i])
end
end.
5.
var
a: array[1..10] of integer;
i: integer;
begin
for i:=1 to 10 do begin
read (a[i]);
if a[i]<0
then a[i]:=a[i]*a[i]
else a[i]:=a[i]*a[i]*a[i];
write (a[i]:4)
end
end.
b) а[2]=8, а[3]=7, а[4]=6.
2. c:=b[11]; b[11]:=b[14]; b[14]:=c;
3.
var
a: array[1..10] of integer;
s,i: integer;
begin
s:=0;
for i:=1 to 10 do begin
read (a[i]);
s:=s+a[i];
end;
writeln (s);
end.
4.
var
a: array[1..10] of integer;
i: integer;
begin
for i:=1 to 10 do begin
read (a[i]);
if a[i]<0 then
writeln (a[i])
end
end.
5.
var
a: array[1..10] of integer;
i: integer;
begin
for i:=1 to 10 do begin
read (a[i]);
if a[i]<0
then a[i]:=a[i]*a[i]
else a[i]:=a[i]*a[i]*a[i];
write (a[i]:4)
end
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я помогу вам с вашим заданием. Вот решение для каждой части:
- Описание массива:
pascalVAR A: ARRAY [1..5] OF INTEGER;
- Подстановка значений:
pascala[2] = 8, a[3] = 7, a[5] = 6.
- Программа для нахождения суммы элементов массива:
pascalVAR A: ARRAY [1..5] OF INTEGER; Sum, i: INTEGER; BEGIN Sum := 0; FOR i := 1 TO 5 DO Sum := Sum + A[i]; WRITELN('Сумма элементов массива: ', Sum); END.
- Программа для печати отрицательных элементов массива:
pascalVAR A: ARRAY [1..5] OF INTEGER; i: INTEGER; BEGIN FOR i := 1 TO 5 DO IF A[i] < 0 THEN WRITELN('Отрицательный элемент: ', A[i]); END.
- Программа для возведения элементов массива в квадрат или третью степень:
pascalVAR A: ARRAY [1..5] OF INTEGER; i: INTEGER; BEGIN FOR i := 1 TO 5 DO BEGIN IF A[i] < 0 THEN A[i] := A[i] * A[i] // Возвести в квадрат ELSE A[i] := A[i] * A[i] * A[i]; // Возвести в третью степень END; FOR i := 1 TO 5 DO WRITELN('Элемент ', i, ': ', A[i]); END.
Пожалуйста, учтите, что в примерах выше массив A объявлен, но не инициализирован значениями. Вам нужно будет добавить инициализацию элементов массива перед использованием.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
