Вопрос задан 09.08.2023 в 02:20.
Предмет Информатика.
Спрашивает Ватаманюк Никита.
Написать программу, которая вводит с клавиатуры последовательность из 5-ти вещественных чисел
и после ввода каждого числа выводит среднее арифметическое полученной части последовательности На паскале (через for to do)Ответы на вопрос
Отвечает Афтаевы Саша-И-Ваня.
Var a,s:real; i:integer;
begin
s:=0;
for i:=1 to 5 do
begin
readln(a);
s:=s+a;
writeln(s/i:5:2);
end;
end.
Пример:
2.8
2.80
9.4
6.10
0.7
4.30
6.0
4.72
4.1
4.60
begin
s:=0;
for i:=1 to 5 do
begin
readln(a);
s:=s+a;
writeln(s/i:5:2);
end;
end.
Пример:
2.8
2.80
9.4
6.10
0.7
4.30
6.0
4.72
4.1
4.60
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Pascal, которая выполняет описанное вами задание:
pascalprogram CalculateAverages; var i: Integer; sum, num: Real; begin sum := 0; writeln('Введите 5 вещественных чисел:'); for i := 1 to 5 do begin readln(num); sum := sum + num; writeln('Среднее арифметическое после ввода ', i, ' числа: ', sum / i:0:2); end; end.
Этот код позволяет вам ввести последовательность из 5 вещественных чисел и после каждого ввода выводит среднее арифметическое для полученной части последовательности. Вы можете скомпилировать и выполнить эту программу средой разработки Pascal (например, Free Pascal).
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 312
Информатика 23
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
