Вопрос задан 06.08.2023 в 15:42.
Предмет Информатика.
Спрашивает Винской Алексей.
Написать программу, которая показывает пользователю на экран три страны и предлагает выбрать одну.
После того, как пользователь выберет страну, программа показывает три города (для какой-то страны может показать правильно, для какой-то - нет) и спрашивает пользователя, относятся ли эти города к выбранной им стране. После ответа пользователя, программа сообщает ему, правильно он ответил, или нет. на С++Ответы на вопрос
Отвечает Тихомирова Олеся.
С этим не сюда, тебе прямиком ... НА форумы по программированию(могу в лс дать парочку), там тебе должны помочь, если вежливо попросить. Удачи!
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на C++, которая реализует описанное вами поведение:
cpp#include <iostream>
#include <string>
#include <cstdlib> // Для генерации случайных чисел
int main() {
srand(time(nullptr)); // Инициализация генератора случайных чисел
std::string countries[] = {"Россия", "США", "Франция"};
std::string cities[][3] = {
{"Москва", "Санкт-Петербург", "Новосибирск"},
{"Нью-Йорк", "Лос-Анджелес", "Чикаго"},
{"Париж", "Лион", "Марсель"}
};
int selectedCountryIndex = rand() % 3; // Выбираем случайную страну
int selectedCityIndex = rand() % 3; // Выбираем случайный город
std::cout << "Выберите страну:\n";
for (int i = 0; i < 3; ++i) {
std::cout << i + 1 << ". " << countries[i] << std::endl;
}
int userCountryChoice;
std::cin >> userCountryChoice;
userCountryChoice--; // Индексы начинаются с 0
if (userCountryChoice == selectedCountryIndex) {
std::cout << "Отлично! Вы выбрали " << countries[selectedCountryIndex] << ".\n";
std::cout << "Сейчас я покажу вам города. Относятся ли они к выбранной вами стране?\n";
for (int i = 0; i < 3; ++i) {
std::cout << i + 1 << ". " << cities[selectedCountryIndex][i] << std::endl;
}
int userCityChoice;
std::cin >> userCityChoice;
userCityChoice--;
if (userCityChoice == selectedCityIndex) {
std::cout << "Правильно! Город " << cities[selectedCountryIndex][selectedCityIndex] << " действительно относится к стране " << countries[selectedCountryIndex] << ".\n";
} else {
std::cout << "Неправильно. Город " << cities[selectedCountryIndex][selectedCityIndex] << " не относится к стране " << countries[selectedCountryIndex] << ".\n";
}
} else {
std::cout << "К сожалению, вы выбрали страну " << countries[userCountryChoice] << ", а правильный ответ был " << countries[selectedCountryIndex] << ".\n";
}
return 0;
}
Обратите внимание, что в этом примере используется генерация случайных чисел для выбора страны и города, а также программа ожидает ввода пользователя в виде чисел.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 11
Информатика 1255
Информатика 115
Информатика 1220
Информатика 11
Информатика 10
Информатика 66
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
