Вопрос задан 06.08.2023 в 15:28.
Предмет Информатика.
Спрашивает Микрюкова Мария.
Написать программу замещения первой половины строки второй а второй первой в с++
Ответы на вопрос
Отвечает Слепчевич Вика.
#include <iostream>
#include <string>
using namespace std;
int main()
{
string a;
char temp;
cin >> a;
for (int i = 0; i < a.size() / 2; ++i) {
temp = a[i];
a[i] = a[a.size() / 2 + i];
a[a.size() / 2 + i] = temp;
}
cout << a;
}
#include <string>
using namespace std;
int main()
{
string a;
char temp;
cin >> a;
for (int i = 0; i < a.size() / 2; ++i) {
temp = a[i];
a[i] = a[a.size() / 2 + i];
a[a.size() / 2 + i] = temp;
}
cout << a;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на C++, которая выполняет замещение первой половины строки второй половиной, а второй половины строки первой половиной:
cpp#include <iostream>
#include <string>
int main() {
std::string input;
std::cout << "Введите строку: ";
std::getline(std::cin, input);
int length = input.length();
int halfLength = length / 2;
if (length % 2 == 0) {
std::string firstHalf = input.substr(0, halfLength);
std::string secondHalf = input.substr(halfLength);
// Заменяем первую половину строки второй половиной
input.replace(0, halfLength, secondHalf);
// Заменяем вторую половину строки первой половиной
input.replace(halfLength, halfLength, firstHalf);
std::cout << "Результат: " << input << std::endl;
} else {
std::cout << "Длина строки должна быть четной." << std::endl;
}
return 0;
}
Программа сначала запрашивает у пользователя строку, затем проверяет, является ли длина строки четным числом. Если да, то она разделяет строку на две половины, заменяет их местами и выводит результат. Если длина строки нечетная, программа выводит сообщение об ошибке.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
