Вопрос задан 02.08.2023 в 03:22.
Предмет Информатика.
Спрашивает Константинов Егор.
PascalABC.net Если можно то сделайте по простому Теперь, когда торговля в городе
процветает, пришло время подумать о долгосрочных перспективах. В вашу казну недавно пришло n поступлений по k сентиннеалей. Вы решили инвестировать их в промышленность и рассчитываете на ежегодное увеличение своего вложения в m раз. Рассчитайте, сколько сентиннеалей у вас будет через х лет. Формат входных данных В первой строке вводится целое число денежных поступлений n (1 <= n <= 100) Во второй строке вводится n целых чисел k в строчку, где k - каждое из постулений (1<= k <=10000) В третьей строке вводятся целые числа x и m - количество лет, в течении которых будет накапливаться итоговая сумма (1<= x <=10), и число раз, в которые будет увеличиваться сумма каждый год (2<= m <=12) Формат выходных данных Выводится целое число, равное итоговой сумме накоплений. Примеры входные данные 5 2 2 5 4 2 1 2 выходные данные 30Ответы на вопрос
Отвечает Меркель Елена.
// PascalABC.NET 3.3
begin
var n:=ReadInteger('n =');
var k:=ReadSeqInteger(n);
var s:=k.Sum;
var (x,m):=ReadInteger2;
writeln(s*power(m,x)); // s*(m**x)
end.
Пример:
5
2 2 5 4 2
3 2
120
begin
var n:=ReadInteger('n =');
var k:=ReadSeqInteger(n);
var s:=k.Sum;
var (x,m):=ReadInteger2;
writeln(s*power(m,x)); // s*(m**x)
end.
Пример:
5
2 2 5 4 2
3 2
120
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи, мы можем написать программу на языке PascalABC.net. Ниже представлен пример кода:
pascalprogram Investment; var n, x, m, i, k: integer; totalSum, currentSum: longint; begin // Ввод данных readln(n); // Инициализация итоговой суммы totalSum := 0; // Цикл для обработки каждого поступления for i := 1 to n do begin read(k); totalSum := totalSum + k; // Прибавляем текущее поступление к общей сумме end; // Ввод количества лет и множителя m readln(x, m); // Цикл для расчета накоплений через x лет с учетом увеличения вложений for i := 1 to x do begin currentSum := totalSum * m; // Рассчитываем текущую сумму через m лет totalSum := currentSum; // Обновляем общую сумму end; // Вывод результата writeln(totalSum); end.
Программа считывает данные, обрабатывает поступления, а затем рассчитывает общую сумму накоплений через x лет с учетом увеличения вложений в m раз. В результате, программа выводит итоговую сумму накоплений.
Похожие вопросы
Информатика 15
Информатика 11
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
