Вопрос задан 30.03.2021 в 03:06.
Предмет Информатика.
Спрашивает Пафиков Виктор.
PascalABC.net Пожалуйста, решите используя только: int64, begin, var, for, if, end. Больше
добавлять переменных не надо. Даю 98 баллов Теперь, когда торговля в городе процветает, пришло время подумать о долгосрочных перспективах. В вашу казну недавно пришло n поступлений по k сентиннеалей. Вы решили инвестировать их в промышленность и рассчитываете на ежегодное увеличение своего вложения в m раз. Рассчитайте, сколько сентиннеалей у вас будет через х лет. Формат входных данных В первой строке вводится целое число денежных поступлений n (1 <= n <= 100) Во второй строке вводится n целых чисел k в строчку, где k - каждое из постулений (1<= k <=10000) В третьей строке вводятся целые числа x и m - количество лет, в течении которых будет накапливаться итоговая сумма (1<= x <=10), и число раз, в которые будет увеличиваться сумма каждый год (2<= m <=12) Формат выходных данных Выводится целое число, равное итоговой сумме накоплений. Примеры входные данные 5 2 2 5 4 2 1 2 выходные данные 30Ответы на вопрос
Отвечает Кравченко Наташа.
var
n, k, x, m: int64;
begin
readln(n);
for x := 1 to n do begin
read(k);
n += k-1;
end;
readln(x, m);
writeln(n*x*m);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот решение вашей задачи на языке PascalABC.NET:
pascalprogram Main; var n, i, k, x, m: int64; begin readln(n); // Вводим количество поступлений k := 0; for i := 1 to n do begin readln(k); // Вводим поступление x := x + k; // Накапливаем сумму end; readln(x, m); // Вводим количество лет и коэффициент увеличения for i := 1 to x do x := x * m; // Увеличиваем сумму x раз writeln(x); // Выводим итоговую сумму накоплений end.
Программа сначала считывает количество поступлений n, затем в цикле считывает n поступлений и накапливает их сумму в переменной x. Затем считывает количество лет x и коэффициент увеличения m. Далее в цикле увеличивает сумму x на m раз и выводит итоговую сумму накоплений.
Надеюсь, это решение поможет вам! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
