
Вопрос задан 02.08.2023 в 00:22.
Предмет Информатика.
Спрашивает Ильина Варвара.
На С++ Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх
целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы. Выходные данные Программа должна вывести сумму, произведение и среднее арифметическое введенных чисел. Среднее арифметическое нужно вывести с точностью 3 знака после десятичной точки. Примеры входные данные 4 5 7 выходные данные 4+5+7=16 4*5*7=140 (4+5+7)/3=5.333

Ответы на вопрос

Отвечает Бакланова Яна.
Почему-то код постоянно плывёт, поэтому я прикрепил решение скрином.




Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи на C++, вы можете использовать следующий код:
cpp#include <iostream>
#include <iomanip>
int main() {
int num1, num2, num3;
// Ввод трёх целых чисел с клавиатуры
std::cout << "Введите три целых числа через пробел: ";
std::cin >> num1 >> num2 >> num3;
// Вычисление суммы, произведения и среднего арифметического
int sum = num1 + num2 + num3;
int product = num1 * num2 * num3;
double average = static_cast<double>(sum) / 3;
// Вывод результатов с точностью 3 знака после десятичной точки
std::cout << num1 << "+" << num2 << "+" << num3 << "=" << sum << std::endl;
std::cout << num1 << "*" << num2 << "*" << num3 << "=" << product << std::endl;
std::cout << std::fixed << std::setprecision(3) << "(" << num1 << "+" << num2 << "+" << num3 << ")/3=" << average << std::endl;
return 0;
}
Этот код считывает три целых числа из строки, вычисляет их сумму, произведение и среднее арифметическое, а затем выводит результаты согласно указанным форматам.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili