С++ Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых
чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы. Выходные данные Программа должна вывести сумму, произведение и среднее арифметическое введенных чисел. Среднее арифметическое нужно вывести с точностью 3 знака после десятичной точки. Примеры входные данные 4 5 7 выходные данные 4+5+7=16 4*5*7=140 (4+5+7)/3=5.333Ответы на вопрос
Ответ:
Хорошо, вот полный и сжатый ответ :
Объяснение:
#include <iostream>
using namespace std;
int main()
{
setlocale(0,"rus");
int a,b,c;
cout << "Три числа : "<< endl;
cin >> a>>b>>c;
cout << "Сумма трех чисел : " << a+b+c << endl;
cout << "Произведение трех чисел : " << a*b*c << endl;
cout << "Среднее арифметическое трёх чисел : " << (double)(a+b+c)/3 << endl;
return 0;
}
Пример ниже демонстрирует, как написать программу на языке Python, которая находит сумму, произведение и среднее арифметическое трех целых чисел, введенных с клавиатуры:
```python # Ввод трех целых чисел с клавиатуры numbers = input("Введите три целых числа через пробел: ").split()
# Преобразование строковых значений в целые числа a = int(numbers[0]) b = int(numbers[1]) c = int(numbers[2])
# Вычисление суммы sum = a + b + c
# Вычисление произведения product = a * b * c
# Вычисление среднего арифметического average = (a + b + c) / 3
# Вывод результатов print(f"Сумма: {sum}") print(f"Произведение: {product}") print(f"Среднее арифметическое: {average:.3f}") ```
После запуска программы, она запросит у пользователя ввести три целых числа через пробел. Затем программа вычислит сумму, произведение и среднее арифметическое этих чисел и выведет результаты на экран.
Пример работы программы: ``` Введите три целых числа через пробел: 4 5 7 Сумма: 16 Произведение: 140 Среднее арифметическое: 5.333 ```
Этот код можно запустить в среде разработки Python или скопировать в файл с расширением ".py" и запустить его из командной строки.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
