Вопрос задан 01.08.2023 в 08:43.
Предмет Информатика.
Спрашивает Коваленко Анна.
Написать программу для вывода первых 10 чисел делящихся без остатка на 3 рандомные неповторяющиися
числа (C#)Ответы на вопрос
Отвечает Орёл Азар.
Visual Studio 2017
using System;
class Program {
static void Main() {
var r = new Random();
int[] a = new int[3];
for (int i = 0; i < 3; i++) {
int e = 1; bool t = true;
while (e != 0 && t){
e = r.Next(1, 11);
for (int j = 0; j < 3; j++)
if (e == a[j]) { t = true; break; } else t = false;
}
a[i] = e;
Console.Write(a[i] + " ");
}
Console.WriteLine();
int[] m = new int[10]; int b = 0;
for (int i = 0; i < 10; i++) {
while (b % a[0] != 0 || b % a[1] != 0 || b % a[2] != 0) b++;
m[i] = b;
b++;
Console.Write(m[i]+" ");
}
Console.Read();
}
}
using System;
class Program {
static void Main() {
var r = new Random();
int[] a = new int[3];
for (int i = 0; i < 3; i++) {
int e = 1; bool t = true;
while (e != 0 && t){
e = r.Next(1, 11);
for (int j = 0; j < 3; j++)
if (e == a[j]) { t = true; break; } else t = false;
}
a[i] = e;
Console.Write(a[i] + " ");
}
Console.WriteLine();
int[] m = new int[10]; int b = 0;
for (int i = 0; i < 10; i++) {
while (b % a[0] != 0 || b % a[1] != 0 || b % a[2] != 0) b++;
m[i] = b;
b++;
Console.Write(m[i]+" ");
}
Console.Read();
}
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для создания программы, которая выводит первые 10 чисел, делящихся без остатка на 3 и при этом они должны быть случайными и неповторяющимися, вам понадобится использовать генерацию случайных чисел и проверку уникальности. Вот пример C# программы, которая выполняет это:
csharpusing System;
using System.Collections.Generic;
class Program
{
static void Main()
{
List<int> numbers = new List<int>();
Random random = new Random();
while (numbers.Count < 10)
{
int randomNumber = random.Next(1, 100); // Генерируем случайное число от 1 до 99
// Проверяем, что число делится на 3 без остатка и еще не встречалось в списке
if (randomNumber % 3 == 0 && !numbers.Contains(randomNumber))
{
numbers.Add(randomNumber);
}
}
Console.WriteLine("Первые 10 случайных чисел, делящихся на 3 без остатка:");
foreach (int number in numbers)
{
Console.WriteLine(number);
}
}
}
Пример работы программы:
Первые 10 случайных чисел, делящихся на 3 без остатка: 18 57 30 87 63 99 9 69 45 27
Примечание: В программе используется генерация случайных чисел в диапазоне от 1 до 99 (задается через random.Next(1, 100)). Вы можете изменить диапазон или границы по вашему усмотрению, если требуется другой диапазон чисел.
Похожие вопросы
Информатика 82
Информатика 99
Информатика 30
Информатика 92
Информатика 65
Информатика 15
Информатика 11
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
