Вопрос задан 01.08.2023 в 08:31.
Предмет Информатика.
Спрашивает Дейкун Таня.
Напишите программу: Посчитать количество четных цифр в числе, введенном с клавиатуры. pascal
Ответы на вопрос
Отвечает Петухова Катя.
PascalABC.NET 3.3.5, сборка 1644 от 23.03.2018
Внимание! Если программа не работает, обновите версию!
begin
var (n,k):=(Abs(ReadInteger('n=')),0);
if n=0 then k:=1
else
while n>0 do begin
if (n mod 10).IsEven then k+=1;
n:=n div 10
end;
Writeln('Четных цифр: ',k)
end.
Пример
n= -623451
Четных цифр: 3
Внимание! Если программа не работает, обновите версию!
begin
var (n,k):=(Abs(ReadInteger('n=')),0);
if n=0 then k:=1
else
while n>0 do begin
if (n mod 10).IsEven then k+=1;
n:=n div 10
end;
Writeln('Четных цифр: ',k)
end.
Пример
n= -623451
Четных цифр: 3
Отвечает Голик Данка.
Var
a, b, k : integer;
begin
k := 0;
write('введите число: ');
readln(a);
while a <> 0 do
begin
b := a mod 10;
if b mod 2 = 0 then inc(k);
a := a div 10
Writeln ('Чётных: ', a);
end;
end.
a, b, k : integer;
begin
k := 0;
write('введите число: ');
readln(a);
while a <> 0 do
begin
b := a mod 10;
if b mod 2 = 0 then inc(k);
a := a div 10
Writeln ('Чётных: ', a);
end;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Pascal для подсчета количества четных цифр в числе, введенном с клавиатуры:
pascalprogram CountEvenDigits; var number: Integer; countEvenDigits: Integer; function IsEvenDigit(digit: Integer): Boolean; begin IsEvenDigit := (digit mod 2) = 0; end; begin writeln('Введите число:'); readln(number); countEvenDigits := 0; while number > 0 do begin if IsEvenDigit(number mod 10) then countEvenDigits := countEvenDigits + 1; number := number div 10; end; writeln('Количество четных цифр в числе: ', countEvenDigits); end.
Программа запросит у пользователя ввод числа, затем она будет выполнять цикл, проверяя каждую цифру числа, является ли она четной (проверка с помощью функции IsEvenDigit) и увеличивая счетчик countEvenDigits при необходимости. В конце программы будет выведено количество четных цифр в числе на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 33
Информатика 32
Информатика 51
Информатика 94
Информатика 36
Информатика 22
Информатика 36
Информатика 12
Информатика 13
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
