Вопрос задан 01.03.2021 в 20:28.
Предмет Информатика.
Спрашивает Дворанин Диана.
Напишите программу для Pascal 1) Пользователь вводит число, количество цифр в нем неизвестно, но
последняя цифра = 0. Посчитать количество четных положительных цифр в этом числе.2)Пользователь вводит число, посчитать количество цифр в числе и вывести минимальную цифру.Ответы на вопрос
Отвечает Аскаров Ыкылас.
Program Ex1;
var
s: string;
c: char;
i, n, m, min: integer;
begin
s := '';
m := 0;
n := 0;
min := 10;
writeln('Введите число');
repeat
read(c);
s := s + c;
i := StrToInt(c);
if i mod 2 = 0 then
if c <> '0' then m := m + 1;
// для задания 2)
n := n + 1;
if i < min then min := i
until c = '0';
writeln('Введено число ', s, ', в нем четных цифр- ', m)
end.
program Ex2;
var
s: string;
i, d, n, min: integer;
begin
min := 10;
writeln('Введите число');
readln(s);
n := length(s);
for i := 1 to length(s) do
begin
d := StrToInt(s[i]);
if d < min then min := d
end;
writeln('Введено число ', s, ', в нем цифр- ', n, ', минимальная- ', min)
end.
var
s: string;
c: char;
i, n, m, min: integer;
begin
s := '';
m := 0;
n := 0;
min := 10;
writeln('Введите число');
repeat
read(c);
s := s + c;
i := StrToInt(c);
if i mod 2 = 0 then
if c <> '0' then m := m + 1;
// для задания 2)
n := n + 1;
if i < min then min := i
until c = '0';
writeln('Введено число ', s, ', в нем четных цифр- ', m)
end.
program Ex2;
var
s: string;
i, d, n, min: integer;
begin
min := 10;
writeln('Введите число');
readln(s);
n := length(s);
for i := 1 to length(s) do
begin
d := StrToInt(s[i]);
if d < min then min := d
end;
writeln('Введено число ', s, ', в нем цифр- ', n, ', минимальная- ', min)
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот программы на языке Pascal для выполнения ваших запросов:
- Подсчет количества четных положительных цифр в числе:
pascalprogram CountEvenDigits; var number, digit, evenCount: integer; begin writeln('Введите число (последняя цифра должна быть равна 0): '); readln(number); evenCount := 0; while number <> 0 do begin digit := number mod 10; if (digit > 0) and (digit mod 2 = 0) then evenCount := evenCount + 1; number := number div 10; end; writeln('Количество четных положительных цифр: ', evenCount); end.
- Подсчет количества цифр и вывод минимальной цифры в числе:
pascalprogram CountDigitsAndMin; var number, digit, digitCount, minDigit: integer; begin writeln('Введите число: '); readln(number); digitCount := 0; minDigit := 9; // Предполагаем, что минимальная цифра будет 9 while number <> 0 do begin digit := number mod 10; digitCount := digitCount + 1; if digit < minDigit then minDigit := digit; number := number div 10; end; writeln('Количество цифр в числе: ', digitCount); writeln('Минимальная цифра: ', minDigit); end.
Обратите внимание, что оба этих примера предполагают, что пользователь будет вводить только положительные числа. Если требуется поддержка отрицательных чисел, то вам потребуется добавить соответствующую проверку и обработку.
Топ вопросов за вчера в категории Информатика
Информатика 33
Информатика 32
Информатика 51
Информатика 94
Информатика 36
Информатика 22
Информатика 36
Информатика 12
Информатика 13
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
