Вопрос задан 01.08.2023 в 02:37. Предмет Информатика. Спрашивает Красникова Анастасия.

Напишите программу на языке паскаль По алгоритму Алг Нач вещ p,s P:=2 S:=0 Нц P:=p*1.5 S:=s+p Кц

при p>5 Вывод S Кон Только на стандарте школьной программы.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Майская Евгения.
Program Test;

Var S, P: real;

Begin

P := 2;
S := 0;

Repeat
P := P * 1.5;
S := S + P;

Until (P > 5);

Writeln('S = ', S);

End.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для написания программы на языке Pascal, следуя алгоритму Алг Нач вещ p, s P:=2 S:=0 Нц P:=p*1.5 S:=s+p Кц при p>5 Вывод S Кон, вам потребуется организовать цикл и условие для выполнения алгоритма. Вот как это может выглядеть на стандартном уровне школьной программы:

pascal
program AlgorithmExample; var p, s: Real; begin p := 2; s := 0; repeat p := p * 1.5; s := s + p; until p > 5; WriteLn('S = ', s); end.

Эта программа объявляет две переменные p и s, инициализирует их начальными значениями 2 и 0 соответственно. Затем программа повторяет цикл repeat...until, умножая p на 1.5 и прибавляя его к s, пока p не станет больше 5. После выхода из цикла программа выводит значение s на экран с помощью WriteLn.

Обратите внимание, что в Pascal используются строгие типы данных, поэтому для работы с вещественными числами используется тип Real.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос