 
Вопрос задан 31.07.2023 в 18:36.
Предмет Информатика.
Спрашивает Ковшиков Кирилл.
Дан массив из 10 целых чисел в диапазоне [-10000,10000]. Определите количество чисел,
оканчивающихся на 2. Числа вводятся с клавиатуры! Написать в Паскале) 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Ахмадулина Ирина.
                
                   Program z;              
var a: array [1..10] of integer;
k,i: integer;
begin
k:=0;
for i:=1 to 10 do
readln(a[i]);
for i:=1 to 10 do if a[i] mod 10 = 2 then k:=k+1;
writeln(k);
end.
                                        var a: array [1..10] of integer;
k,i: integer;
begin
k:=0;
for i:=1 to 10 do
readln(a[i]);
for i:=1 to 10 do if a[i] mod 10 = 2 then k:=k+1;
writeln(k);
end.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Вот пример программы на Pascal, которая считывает 10 целых чисел с клавиатуры и определяет количество чисел, оканчивающихся на 2:
pascalprogram CountNumbersEndingWith2; const ArraySize = 10; var Numbers: array[1..ArraySize] of integer; i, CountNumbersEndingWith2: integer; begin CountNumbersEndingWith2 := 0; { Считываем числа с клавиатуры } writeln('Введите 10 целых чисел:'); for i := 1 to ArraySize do begin write('Число ', i, ': '); readln(Numbers[i]); end; { Проверяем каждое число из массива } for i := 1 to ArraySize do begin if Numbers[i] mod 10 = 2 then Inc(CountNumbersEndingWith2); end; writeln('Количество чисел, оканчивающихся на 2: ', CountNumbersEndingWith2); end.
При запуске этой программы она предложит ввести 10 целых чисел с клавиатуры. После ввода всех чисел она подсчитает количество чисел, оканчивающихся на 2, и выведет результат на экран.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			