Вопрос задан 30.07.2023 в 20:41.
Предмет Информатика.
Спрашивает Юлина Владислава.
Паскаль Написать программу для нахождения суммы большего и меньшего из трех чисел. Указание: для
решения задачи использовать подпрограммы вычисления минимального и максимального для двух чисел. Пример на входе: 45 72 24 на выходе: 96Ответы на вопрос
Отвечает Ратцева Анастасия.
Var
a, b, c: integer;
function min_3(const a, b, c: integer): integer;
var
local_min: integer;
begin
if (a < b) then
local_min := a
else
local_min := b;
if (c < local_min) then
local_min := c;
Result := local_min
end;
function max_3(const a, b, c: integer): integer;
var
local_max: integer;
begin
if (a >= b) then
local_max := a
else
local_max := b;
if (c > local_max) then
local_max := c;
Result := local_max;
end;
begin
writeln('Введите a, b, c -> ');
readln(a, b, c);
writeln('Результат: ', min_3(a, b, c) + max_3(a, b, c), '.');
end.
a, b, c: integer;
function min_3(const a, b, c: integer): integer;
var
local_min: integer;
begin
if (a < b) then
local_min := a
else
local_min := b;
if (c < local_min) then
local_min := c;
Result := local_min
end;
function max_3(const a, b, c: integer): integer;
var
local_max: integer;
begin
if (a >= b) then
local_max := a
else
local_max := b;
if (c > local_max) then
local_max := c;
Result := local_max;
end;
begin
writeln('Введите a, b, c -> ');
readln(a, b, c);
writeln('Результат: ', min_3(a, b, c) + max_3(a, b, c), '.');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для написания программы на Паскале, которая находит сумму большего и меньшего из трех чисел, мы можем создать подпрограммы для вычисления минимального и максимального числа из двух чисел. Затем используем эти подпрограммы для определения минимального и максимального числа среди трех введенных чисел и, наконец, вычислим их сумму.
Вот код программы на Паскале:
pascalprogram FindMinMaxSum; // Подпрограмма для нахождения максимального числа из двух function Max(a, b: Integer): Integer; begin if a > b then Max := a else Max := b; end; // Подпрограмма для нахождения минимального числа из двух function Min(a, b: Integer): Integer; begin if a < b then Min := a else Min := b; end; var num1, num2, num3, maxNum, minNum, sum: Integer; begin // Вводим три числа с клавиатуры Write('Введите первое число: '); Readln(num1); Write('Введите второе число: '); Readln(num2); Write('Введите третье число: '); Readln(num3); // Находим максимальное и минимальное число среди num1 и num2 maxNum := Max(num1, num2); minNum := Min(num1, num2); // Сравниваем максимальное и минимальное число с num3 maxNum := Max(maxNum, num3); minNum := Min(minNum, num3); // Вычисляем сумму максимального и минимального чисел sum := maxNum + minNum; // Выводим результат Writeln('Сумма наибольшего и наименьшего чисел: ', sum); end.
Программа просит ввести три числа и выводит сумму наибольшего и наименьшего чисел. Ваш пример "45 72 24" вернет ожидаемый результат "96".
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
