Вопрос задан 30.07.2023 в 13:38.
Предмет Информатика.
Спрашивает Гранкин Даниил.
Паскаль,написать программу: Организовать с клавиатуры ввод N произвольных целых чисел. Определить
количество отрицательных и сумму положительных.Ответы на вопрос
Отвечает Логинова Поля.
Var
n, i, a, kotr, sumpol: longint;
begin
readln(n);
kotr := 0;
sumpol := 0;
for i := 1 to n do begin
read(a);
if (a < 0) then
inc(kotr)
else
sumpol := sumpol + a;
end;
writeln('Количество отрицательных чисел = ', kotr);
writeln('Сумма положительных чисел = ', sumpol);
n, i, a, kotr, sumpol: longint;
begin
readln(n);
kotr := 0;
sumpol := 0;
for i := 1 to n do begin
read(a);
if (a < 0) then
inc(kotr)
else
sumpol := sumpol + a;
end;
writeln('Количество отрицательных чисел = ', kotr);
writeln('Сумма положительных чисел = ', sumpol);
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для написания программы на языке Паскаль, удобно использовать циклы для считывания чисел с клавиатуры и определения их свойств. Вот пример программы, которая решает вашу задачу:
pascalprogram CountPosNegNumbers; var N, num, sumPos, countNeg: integer; begin sumPos := 0; countNeg := 0; writeln('Введите количество чисел N:'); readln(N); writeln('Введите ', N, ' целых чисел:'); for var i := 1 to N do begin readln(num); if num < 0 then countNeg := countNeg + 1 else sumPos := sumPos + num; end; writeln('Количество отрицательных чисел: ', countNeg); writeln('Сумма положительных чисел: ', sumPos); end.
Пользователь должен ввести значение N - количество чисел, а затем последовательно ввести N целых чисел. Программа затем подсчитает количество отрицательных чисел и сумму положительных чисел и выведет их на экран.
Примечание: В Паскале обратите внимание на то, что циклы считаются от 1 до N (включительно), где i - это текущий номер итерации цикла. В программе выше я использовал for var i := 1 to N do для примера, однако в других реализациях Паскаля (например, Turbo Pascal) синтаксис может немного отличаться.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
