
Вопрос задан 30.07.2023 в 07:01.
Предмет Информатика.
Спрашивает Мельниченко Никита.
Написать программу сортировки массива по возрастанию из 10 случайных элементов.паскаль


Ответы на вопрос

Отвечает Рыбалко Сергей.
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,-50,50); a.Println; a.Sorted.Println
end.
Пример
32 23 -44 -39 40 23 -27 13 -36 -41
-44 -41 -39 -36 -27 13 23 23 32 40
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,-50,50); a.Println; a.Sorted.Println
end.
Пример
32 23 -44 -39 40 23 -27 13 -36 -41
-44 -41 -39 -36 -27 13 23 23 32 40



Отвечает Дикун Нелька.
Program aaa;
var
a:array[1..10] of integer;
i,j,x:integer;
begin
randomize;
for i:=1 to 10 do
a[i]:=random(10000)-5000;
for i:=1 to 10 do
write(a[i],' ');
writeln;
for i:=2 to 10 do
for j:=10 downto i do
if(a[j-1]>a[j]) then begin
x:=a[j-1];
a[j-1]:=a[j];
a[j]:=x;
end;
for i:=1 to 10 do
write(a[i],' ');
end.
var
a:array[1..10] of integer;
i,j,x:integer;
begin
randomize;
for i:=1 to 10 do
a[i]:=random(10000)-5000;
for i:=1 to 10 do
write(a[i],' ');
writeln;
for i:=2 to 10 do
for j:=10 downto i do
if(a[j-1]>a[j]) then begin
x:=a[j-1];
a[j-1]:=a[j];
a[j]:=x;
end;
for i:=1 to 10 do
write(a[i],' ');
end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для сортировки массива по возрастанию в Паскале (Pascal), можно использовать алгоритм сортировки "пузырьком" (Bubble Sort), который прост и понятен для понимания. В данном алгоритме происходит сравнение и обмен соседних элементов массива, пока массив не будет отсортирован. Вот пример программы на Паскале, которая сортирует массив из 10 случайных элементов:
pascalprogram BubbleSort; const N = 10; // Размер массива var arr: array[1..N] of Integer; i, j, temp: Integer; begin // Инициализация генератора случайных чисел Randomize; // Заполнение массива случайными значениями for i := 1 to N do arr[i] := Random(100); // Случайное число от 0 до 99 // Вывод исходного массива Writeln('Исходный массив:'); for i := 1 to N do Write(arr[i], ' '); Writeln; // Сортировка массива методом пузырька for i := 1 to N - 1 do for j := 1 to N - i do if arr[j] > arr[j + 1] then begin // Обмен элементов, если текущий больше следующего temp := arr[j]; arr[j] := arr[j + 1]; arr[j + 1] := temp; end; // Вывод отсортированного массива Writeln('Отсортированный массив:'); for i := 1 to N do Write(arr[i], ' '); Writeln; end.
Программа генерирует массив из 10 случайных чисел от 0 до 99, сортирует его по возрастанию методом пузырька и выводит исходный и отсортированный массивы в консоль.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili