Вопрос задан 30.07.2023 в 04:40.
Предмет Информатика.
Спрашивает Жидик Ваня.
Написать программу на паскале, запрашивающую у пользователя его возраст и в зависимости от
введенного возраста выводящую, например, грудничок, детсадовец, школьник, студент, работающий, пенсионерОтветы на вопрос
Отвечает Леонардыч Евгений.
Var age: Integer;
begin
writeln('Введите свой возраст');
readln(age);
if (age>-1) and (age<4) then writeln('малыш');
if (age>3) and (age<7) then writeln('детсадовец');
if (age>6) and (age<17) then writeln('школьник');
if (age>16) and (age<23) then writeln('студент');
if (age>22) and (age<50) then writeln('работник на заводе');
if (age>49) and (age<100) then writeln('пенсионер');
end.
begin
writeln('Введите свой возраст');
readln(age);
if (age>-1) and (age<4) then writeln('малыш');
if (age>3) and (age<7) then writeln('детсадовец');
if (age>6) and (age<17) then writeln('школьник');
if (age>16) and (age<23) then writeln('студент');
if (age>22) and (age<50) then writeln('работник на заводе');
if (age>49) and (age<100) then writeln('пенсионер');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для написания программы на Pascal, которая запрашивает у пользователя возраст и выводит соответствующее сообщение, можно использовать следующий код:
pascalprogram AgeClassifier; var age: Integer; begin WriteLn('Введите ваш возраст:'); ReadLn(age); case age of 0..2: WriteLn('Вы грудничок.'); 3..6: WriteLn('Вы детсадовец.'); 7..17: WriteLn('Вы школьник.'); 18..24: WriteLn('Вы студент.'); 25..59: WriteLn('Вы работающий.'); else WriteLn('Вы пенсионер.'); end; end.
Программа предложит пользователю ввести его возраст. Затем с помощью оператора case будет определено, в каком диапазоне находится введенный возраст, и в зависимости от этого выводится соответствующее сообщение о его статусе.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
