Вопрос задан 30.07.2023 в 02:16.
Предмет Информатика.
Спрашивает Давиденко Павел.
Написать программу нахождения максимального и минимального из двух заданных чисел. с++
Ответы на вопрос
Отвечает Осипова София.
#include <iostream>
int main()
{
int max_num, min_num, tmp;
std::cout « "Enter two numbers: ";
std::cin » max_num » min_num;
if (max_num < min_num)
{
tmp = max_num;
max_num = min_num;
min_num = tmp;
}
std::cout « "\nMax: " « max_num « "\nMin: " « min_num;
return 0;
}
int main()
{
int max_num, min_num, tmp;
std::cout « "Enter two numbers: ";
std::cin » max_num » min_num;
if (max_num < min_num)
{
tmp = max_num;
max_num = min_num;
min_num = tmp;
}
std::cout « "\nMax: " « max_num « "\nMin: " « min_num;
return 0;
}


Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для нахождения максимального и минимального из двух заданных чисел в C++, вы можете использовать следующий код:
cpp#include <iostream>
int main() {
int num1, num2;
// Вводим два числа
std::cout << "Введите первое число: ";
std::cin >> num1;
std::cout << "Введите второе число: ";
std::cin >> num2;
// Находим максимальное и минимальное число
int maxNum = (num1 > num2) ? num1 : num2;
int minNum = (num1 < num2) ? num1 : num2;
// Выводим результаты
std::cout << "Максимальное число: " << maxNum << std::endl;
std::cout << "Минимальное число: " << minNum << std::endl;
return 0;
}
Программа просит пользователя ввести два числа, затем сравнивает их и находит максимальное и минимальное число. Результаты выводятся на экран. Если первое число равно второму, то они считаются и максимальным и минимальным.
Похожие вопросы
Информатика 82
Информатика 99
Информатика 31
Информатика 22
Информатика 173
Информатика 42
Информатика 65
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
