Вопрос задан 30.07.2023 в 00:55. Предмет Информатика. Спрашивает Любченко Андрей.

Программисты, помогите!!!! нужно написать программу на паскале дано натуральное число n. Найти

произведение нечетных чисел от 1 до n. C Longint и integer.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Новожилов Александр.
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  Writeln(Range(1,ReadInteger,2).Aggregate(BigInteger(1),(p,q)->p*q))
end.

0 0
Отвечает Макаренко Анастасия.
Var
  n, i: integer;
  pr: longint;

begin
  readln(n);
  pr := 1;
  i := 1;
  while (i <= n) do begin
    i := i + 2;
    pr := pr * i;
  end;
  pr := pr div i;
  writeln(pr);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я помогу вам написать программу на Pascal для нахождения произведения нечетных чисел от 1 до заданного натурального числа n. В Pascal есть два встроенных целочисленных типа: Integer и Longint. Вам понадобится использовать Longint, чтобы обеспечить достаточную точность для больших значений произведения.

Вот программа на Pascal:

pascal
program MultiplyOddNumbers; var n: Integer; product: Longint; function MultiplyOdds(n: Integer): Longint; var i: Integer; begin product := 1; for i := 1 to n do begin if i mod 2 = 1 then product := product * i; end; MultiplyOdds := product; end; begin writeln('Введите натуральное число n:'); readln(n); if n < 1 then writeln('Ошибка: введенное число должно быть больше или равно 1') else writeln('Произведение нечетных чисел от 1 до ', n, ': ', MultiplyOdds(n)); end.

Программа предлагает пользователю ввести натуральное число n. Затем она находит произведение всех нечетных чисел от 1 до n и выводит результат на экран.

Убедитесь, что компилятор Pascal поддерживает тип Longint, так как некоторые компиляторы могут использовать другое имя для этого типа (например, Int64). Если ваш компилятор использует другое имя, замените "Longint" на соответствующее имя типа.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос