Вопрос задан 29.07.2023 в 12:34.
Предмет Информатика.
Спрашивает Франт Діана.
Даю 90 балов напишите программу плиз на C++ Если что учусь на 1 курсе Ввести с клавиатуры
целочисленную матрицу размера 4X4. Найти номер строки матрицы с максимальной суммой элементов.Ответы на вопрос
Отвечает Азанова Диана.
Написать тут код не удалось, сайт не так скопировал. Я тебе .cpp файл прикрепил, качай и пользуйся. Сам писал тебе, чтоб тебе спокойней было :)
P.S: .exe файл загрузить не удалось и если что с телефона его не скачать, только с ПК. У меня всё.
P.S: .exe файл загрузить не удалось и если что с телефона его не скачать, только с ПК. У меня всё.

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот программа на C++ для нахождения номера строки матрицы 4x4 с максимальной суммой элементов:
cpp#include <iostream>
using namespace std;
int main() {
const int rows = 4;
const int cols = 4;
int matrix[rows][cols];
// Ввод матрицы с клавиатуры
cout << "Введите элементы матрицы 4x4:\n";
for (int i = 0; i < rows; ++i) {
for (int j = 0; j < cols; ++j) {
cin >> matrix[i][j];
}
}
int maxSum = 0; // Максимальная сумма элементов в строке
int maxSumRow = 0; // Номер строки с максимальной суммой элементов
// Находим номер строки с максимальной суммой элементов
for (int i = 0; i < rows; ++i) {
int sum = 0;
for (int j = 0; j < cols; ++j) {
sum += matrix[i][j];
}
if (sum > maxSum) {
maxSum = sum;
maxSumRow = i;
}
}
// Выводим результат
cout << "Номер строки с максимальной суммой элементов: " << maxSumRow << endl;
return 0;
}
Программа позволит вам ввести элементы матрицы размером 4x4 с клавиатуры и найдет номер строки, в которой сумма элементов максимальна. Если у вас возникнут какие-либо вопросы, не стесняйтесь задавать!
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
