Вопрос задан 29.07.2023 в 11:48.
Предмет Информатика.
Спрашивает Кючюк Серг.
Как в C++ написать программу, чтобы она спрашивала твоё имя, а затем здоровалась с тобой. Я пишу,
вроде всё правильно делаю, но программа выдает: "Hello, 0", чтобы я не вводила. #include ; using namespace std; int main() { int name; cout << "What is your name?"; cin >> name; cout << "Hello," << name<< endl; return 0; }Ответы на вопрос
Отвечает Муратова Дмитрий.
По порядку:
1) Ты забыл подключить библиотеку <iostream> (надо было наприсать
#include <iostream>)
2) int - тип целочисленных переменных - они могут принимать лишь значения, что не удивительно, целых чисел. Для твоей цели необходимо использовать строковую переменную, в C++ - это string (Для ее использования необходимо ее подключить - #include <string>)
Итого
#include <iostream>
#include <string>
using namespace std;
int main() {
string name;
cout << "What is your name?";
cin >> name;
cout << "Hello, " << name<< endl;
return 0;
}
1) Ты забыл подключить библиотеку <iostream> (надо было наприсать
#include <iostream>)
2) int - тип целочисленных переменных - они могут принимать лишь значения, что не удивительно, целых чисел. Для твоей цели необходимо использовать строковую переменную, в C++ - это string (Для ее использования необходимо ее подключить - #include <string>)
Итого
#include <iostream>
#include <string>
using namespace std;
int main() {
string name;
cout << "What is your name?";
cin >> name;
cout << "Hello, " << name<< endl;
return 0;
}
Отвечает Sindukova Natasha.
Достаточно массива char str[10] и не нужно ничего лишнего подключать, прежде чем переходить к <string> из С++, стоить ознакомится со Си строками, тк <string> это только удобная обертка
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Проблема вашей программы заключается в том, что вы используете переменную name как int, то есть как целое число, вместо того, чтобы использовать ее для хранения строки (имени). Вам следует использовать тип string из пространства имен std, чтобы сохранить введенное имя как строку.
Вот исправленный код:
cpp#include <iostream>
#include <string> // Добавляем заголовочный файл для работы со строками
using namespace std;
int main() {
string name; // Используем тип string для хранения имени
cout << "What is your name?";
cin >> name;
cout << "Hello, " << name << endl;
return 0;
}
Теперь программа будет запрашивать ваше имя, сохранять его как строку и затем приветствовать вас по имени.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
