Вопрос задан 29.07.2023 в 11:21.
Предмет Информатика.
Спрашивает Сопов Ростислав.
Информатика,Паскаль,написать программу: Сформировать массив, состоящий из n целых элементов,
лежащих в промежутке [10;10] Вычислить: -минимальный по модулю элемент - количество элементов кратных 5 - сумму элементов массива, расположенных между первым и последним положительными элементами.Ответы на вопрос
Отвечает Панарин Евгений.
PascalABC.NET 3.4.0, сборка 1671 от 31.05.2018
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
Writeln('Минимальный по модулю элемент равен ',
a.Select(t->Abs(t)).Min);
Writeln('Количество элементов, кратных 5, равно ',
a.Where(t->t mod 5=0).Count);
Write('Сумма искомых элементов равна ');
var ai:=a.Indexesof(t->t>0);
a[ai.First+1:ai.Last].Sum.Println;
end.
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
Writeln('Минимальный по модулю элемент равен ',
a.Select(t->Abs(t)).Min);
Writeln('Количество элементов, кратных 5, равно ',
a.Where(t->t mod 5=0).Count);
Write('Сумма искомых элементов равна ');
var ai:=a.Indexesof(t->t>0);
a[ai.First+1:ai.Last].Sum.Println;
end.

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для написания программы на языке Паскаль, которая выполняет указанные действия, следуйте следующему коду:
pascalprogram ArrayOperations; const N = 10; // Задайте желаемый размер массива var arr: array[1..N] of integer; i, firstPositiveIndex, lastPositiveIndex, minAbsElement, countMultiplesOf5, sumBetweenPositives: integer; begin // Заполнение массива случайными числами от -10 до 10 for i := 1 to N do arr[i] := Random(21) - 10; // Вывод исходного массива writeln('Исходный массив:'); for i := 1 to N do write(arr[i]:4); // Поиск минимального по модулю элемента minAbsElement := abs(arr[1]); for i := 2 to N do begin if abs(arr[i]) < minAbsElement then minAbsElement := abs(arr[i]); end; writeln; writeln('Минимальный по модулю элемент: ', minAbsElement); // Подсчет количества элементов, кратных 5 countMultiplesOf5 := 0; for i := 1 to N do begin if arr[i] mod 5 = 0 then countMultiplesOf5 := countMultiplesOf5 + 1; end; writeln('Количество элементов, кратных 5: ', countMultiplesOf5); // Поиск первого и последнего положительных элементов firstPositiveIndex := 0; lastPositiveIndex := 0; for i := 1 to N do begin if arr[i] > 0 then begin if firstPositiveIndex = 0 then firstPositiveIndex := i else lastPositiveIndex := i; end; end; // Подсчет суммы элементов между первым и последним положительными элементами sumBetweenPositives := 0; if (firstPositiveIndex <> 0) and (lastPositiveIndex <> 0) then begin for i := firstPositiveIndex + 1 to lastPositiveIndex - 1 do sumBetweenPositives := sumBetweenPositives + arr[i]; end; writeln('Сумма элементов между первым и последним положительными элементами: ', sumBetweenPositives); end.
Примечание:
- В этом примере используется случайная генерация чисел от -10 до 10, чтобы заполнить массив. Вы можете изменить эту часть кода или ввести значения массива с клавиатуры, если предпочитаете.
- Код рассчитан на массив из 10 элементов (N = 10), но вы можете изменить значение N на любое желаемое количество элементов.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 22
Информатика 36
Информатика 60
Информатика 2166
Информатика 10
Информатика 571
Информатика 49
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
