Вопрос задан 29.07.2023 в 05:52.
Предмет Информатика.
Спрашивает Лосицкий Саша.
На языке программирования Pascal составить программу, которая находит среднее арифметическое чисел,
введенных с клавиатуры. Концом ввода чисел считать ввод 0. (числа 22 и 66)Ответы на вопрос
Отвечает Чернова Александра.
// PascalABC.NET 3.4
begin
ReadSeqIntegerWhile(n->n<>0).Average.Println
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для нахождения среднего арифметического чисел, введенных с клавиатуры, в языке программирования Pascal, вы можете использовать следующий код:
pascalprogram CalculateAverage; var num, sum, count: integer; average: real; begin sum := 0; count := 0; writeln('Введите числа. Ввод 0 прекратит ввод и вычислит среднее арифметическое.'); repeat readln(num); if num <> 0 then begin sum := sum + num; count := count + 1; end; until num = 0; if count > 0 then begin average := sum / count; writeln('Среднее арифметическое:', average:0:2); end else writeln('Вы не ввели числа для вычисления среднего арифметического.'); readln; end.
Обратите внимание, что в данной программе ввод чисел прекратится при вводе 0. Затем программа вычислит и выведет среднее арифметическое введенных чисел на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
