Вопрос задан 28.07.2023 в 17:10.
Предмет Информатика.
Спрашивает Илахунов Шадияр.
Составить программу Паскаль: найти количество чётных и количество нечетных чисел из четырёх
введенных чисел.Ответы на вопрос
Отвечает Курганская Анна.
// PascalABC.NET 3.4.2, сборка 1790 от 15.09.2018
// Внимание! Если программа не работает, обновите версию!
begin
var Нечетных := ReadSeqInteger('Введите 4 числа:', 4)
.Where(k -> k.IsOdd).Count;
Println('Нечетных:', Нечетных, 'четных', 4 - Нечетных)
end.
Отвечает Бокач Ярослав.
найти количество чётных и

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для написания программы на языке Паскаль, которая будет находить количество чётных и нечетных чисел из четырёх введенных пользователем чисел, можно использовать следующий код:
pascalprogram CountEvenAndOdd; var num1, num2, num3, num4: Integer; evenCount, oddCount: Integer; begin evenCount := 0; oddCount := 0; // Ввод чисел с клавиатуры Write('Введите первое число: '); ReadLn(num1); Write('Введите второе число: '); ReadLn(num2); Write('Введите третье число: '); ReadLn(num3); Write('Введите четвертое число: '); ReadLn(num4); // Проверка четности и увеличение счетчиков if num1 mod 2 = 0 then evenCount := evenCount + 1 else oddCount := oddCount + 1; if num2 mod 2 = 0 then evenCount := evenCount + 1 else oddCount := oddCount + 1; if num3 mod 2 = 0 then evenCount := evenCount + 1 else oddCount := oddCount + 1; if num4 mod 2 = 0 then evenCount := evenCount + 1 else oddCount := oddCount + 1; // Вывод результатов WriteLn('Количество чётных чисел: ', evenCount); WriteLn('Количество нечетных чисел: ', oddCount); end.
Программа просит пользователя ввести четыре числа с клавиатуры, затем проверяет каждое число на четность и соответствующим образом увеличивает счетчики четных и нечетных чисел. После этого выводит результаты подсчета на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 266
Информатика 25
Информатика 33
Информатика 16
Информатика 10
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
