Написать программу в Паскале. Даны два числа, если первое больше второго, то найти разницу. В
обратном случае найти произведениеОтветы на вопрос
var
a, b, s, integer;
begin
readln(a, b);
if a>b then s:=a-b
else s:=a*b;
writeln(s);
readln;
end.
Даны два числа, если первое больше второго, то...

Для написания программы в Паскале, которая будет выполнять описанные вами действия, следуйте этим шагам:
Откройте среду разработки Pascal (например, Lazarus или Free Pascal) и создайте новый проект.
Напишите следующий код:
pascalprogram CompareAndCalculate; var num1, num2, result: integer; // Используем тип integer для работы с целыми числами begin // Вводим два числа с клавиатуры Write('Введите первое число: '); ReadLn(num1); Write('Введите второе число: '); ReadLn(num2); // Проверяем условие и выполняем соответствующее действие if num1 > num2 then begin // Если первое число больше второго, находим разницу result := num1 - num2; WriteLn('Разница: ', result); end else begin // Иначе находим произведение result := num1 * num2; WriteLn('Произведение: ', result); end; ReadLn; // Чтобы программа не закрылась сразу после выполнения end.
Сохраните файл и скомпилируйте программу. Если нет ошибок, запустите программу.
Введите два числа, и программа выдаст результат в соответствии с описанными условиями.
Программа предлагает вам ввести два числа с клавиатуры. Если первое число больше второго, программа найдет и выведет разницу между ними. В противном случае, если первое число не больше второго, программа найдет и выведет их произведение.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
