Вопрос задан 28.07.2023 в 07:06.
Предмет Информатика.
Спрашивает Гекк Влад.
Напишите программу для Pascal (найти больше число из 3) для чисел 5 1 5 1 2 4 4 4 1 5 5 5 4 2 5 2
5 4Ответы на вопрос
Отвечает Мокиевский Олег.
// PascalABC.NET 3.4.2, сборка 1797 от 22.09.2018
// Внимание! Если программа не работает, обновите версию!
begin
loop 6 do
ReadSeqInteger('==>',3).Max.Println
end.

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для нахождения наибольшего числа из трех входных чисел в Pascal, вы можете использовать следующий код:
pascalprogram FindMaxNumber; var num1, num2, num3, max: Integer; begin Write('Введите первое число: '); Readln(num1); Write('Введите второе число: '); Readln(num2); Write('Введите третье число: '); Readln(num3); if (num1 >= num2) and (num1 >= num3) then max := num1 else if (num2 >= num1) and (num2 >= num3) then max := num2 else max := num3; Writeln('Наибольшее число: ', max); end.
Однако, если вы хотите найти наибольшее число из списка, как указано в вашем вопросе, вам нужно будет пройтись по списку и сравнить каждое число с текущим максимальным числом. Вот пример программы для этого:
pascalprogram FindMaxNumberInList; var numbers: array[1..19] of Integer; i, max: Integer; begin numbers[1] := 5; numbers[2] := 1; numbers[3] := 5; numbers[4] := 1; numbers[5] := 2; numbers[6] := 4; numbers[7] := 4; numbers[8] := 4; numbers[9] := 1; numbers[10] := 5; numbers[11] := 5; numbers[12] := 5; numbers[13] := 4; numbers[14] := 2; numbers[15] := 5; numbers[16] := 2; numbers[17] := 5; numbers[18] := 4; max := numbers[1]; for i := 2 to 19 do begin if numbers[i] > max then max := numbers[i]; end; Writeln('Наибольшее число в списке: ', max); end.
Обратите внимание, что в этом примере список чисел представлен массивом numbers. Вы можете добавить / изменить числа в массиве, чтобы анализировать другие входные данные.
Похожие вопросы
Информатика 78
Информатика 94
Информатика 26
Информатика 345
Информатика 64
Информатика 45
Информатика 76
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
