Вопрос задан 28.07.2023 в 00:52.
Предмет Информатика.
Спрашивает Демьянова Дарья.
Составьте программу на Паскале для вычисления n+5 для нечётного целого числа n и n^2 для чётного n.
Ответы на вопрос
Отвечает Асташенко Семён.
var n:integer;
begin
readln(n);
if n mod 2 = 0 then
writeln(n*n)
else writeln(n+5);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот программа на языке Паскаль, которая вычисляет n+5 для нечётного целого числа n и n^2 для чётного n:
pascalprogram CalculateNPlusFiveOrN2; var n, result: integer; begin // Вводим значение n write('Введите целое число n: '); readln(n); // Проверяем, является ли n нечётным if n mod 2 = 1 then begin // Если n нечётное, вычисляем n + 5 result := n + 5; writeln('n + 5 = ', result); end else begin // Если n чётное, вычисляем n^2 result := n * n; writeln('n^2 = ', result); end; end.
Программа запрашивает у пользователя значение n, а затем проверяет, является ли оно нечётным или чётным. В зависимости от результата, программа вычисляет n + 5 для нечётного n или n^2 для чётного n и выводит результат на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 33
Информатика 32
Информатика 51
Информатика 94
Информатика 36
Информатика 22
Информатика 36
Информатика 12
Информатика 13
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
