написать программу паскаль : вводится возраст человека выдать его статус 1-7 ребёнок 8-18 школьник
19-24 студент 25-65 рабочий от 65 пенсионерОтветы на вопрос
var years:integer;
begin
readln(years);
case years of
1..7: writeln('Ребенок');
8..18: writeln('Школьник');
19..24: writeln('Студент');
25..65: writeln('Рабочий');
66..150: writeln('Пенсионер');(*Вряд ли до 150 кто-то доживет, но все же*)
end;
end.
Для написания программы на языке Паскаль, которая определяет статус человека по его возрасту, нужно использовать конструкцию условных операторов. Вот пример программы:
pascalprogram AgeStatus; var age: integer; begin writeln('Введите возраст человека:'); readln(age); if (age >= 1) and (age <= 7) then writeln('Ребёнок') else if (age >= 8) and (age <= 18) then writeln('Школьник') else if (age >= 19) and (age <= 24) then writeln('Студент') else if (age >= 25) and (age <= 65) then writeln('Рабочий') else writeln('Пенсионер'); readln; end.
В этой программе мы сначала объявляем переменную age, в которую пользователь будет вводить возраст. Затем с помощью условных операторов if-else проверяем возраст и выводим соответствующий статус.
Обратите внимание, что здесь предполагается, что пользователь вводит корректные числа. В реальном приложении стоит добавить дополнительные проверки для обработки некорректного ввода.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
