Вопрос задан 27.07.2023 в 09:29.
Предмет Информатика.
Спрашивает Ананьева Анна.
Напишите программу которая находит минимальное и максимальное среди положительных чисел, записанных
в файле и выводит из в другой файл.Учтите,что таких чисел может и не быть Прошу очень поскорей На паскалеОтветы на вопрос
Отвечает Ковалевская Кристина.
PascalABC.NET 3.4.2, сборка 1837 от 11.10.2018
Внимание! Если программа не работает, обновите версию!
begin
var a := ReadAllText('input.txt').ToIntegers.Where(t -> t > 0);
if a.Count>0 then WriteAllText('output.txt', $'{a.Min} {a.Max}')
end.
Первое вложение - файл input.txt, второе - output.txt


Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Хорошо, вот программа на языке Паскаль, которая читает числа из одного файла, находит минимальное и максимальное среди положительных чисел, а затем записывает результаты в другой файл:
pascalprogram MinMaxPositiveNumbers; var inputFile, outputFile: Text; num, min, max: real; foundPositive: boolean; begin // Открываем файлы для чтения и записи Assign(inputFile, 'input.txt'); Assign(outputFile, 'output.txt'); Reset(inputFile); Rewrite(outputFile); // Инициализируем переменные перед обработкой min := 0; // Минимальное положительное число (предполагаем, что оно >= 0) max := 0; // Максимальное положительное число (предполагаем, что оно >= 0) foundPositive := False; // Флаг для определения, были ли найдены положительные числа // Читаем числа из файла и обрабатываем каждое while not Eof(inputFile) do begin Read(inputFile, num); // Проверяем, что число положительное if num > 0 then begin // Если это первое найденное положительное число, то инициализируем min и max if not foundPositive then begin min := num; max := num; foundPositive := True; end else begin // Иначе обновляем min и max при необходимости if num < min then min := num; if num > max then max := num; end; end; end; // Закрываем файлы Close(inputFile); Close(outputFile); // Если были найдены положительные числа, то выводим результаты в файл if foundPositive then begin Rewrite(outputFile); Write(outputFile, 'Минимальное положительное число: ', min:0:2); WriteLn(outputFile); Write(outputFile, 'Максимальное положительное число: ', max:0:2); Close(outputFile); WriteLn('Результаты были успешно записаны в файл output.txt'); end else WriteLn('В файле нет положительных чисел'); end.
Чтобы использовать эту программу, создайте текстовый файл с именем "input.txt" и запишите в него числа, разделенные пробелами или переносами строк. Затем запустите программу, и она найдет минимальное и максимальное среди положительных чисел и запишет результаты в файл "output.txt". Если в файле нет положительных чисел, программа сообщит об этом.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
