Вопрос задан 27.07.2023 в 08:06. Предмет Информатика. Спрашивает Шиморина Лилечка.

С++ Составить программу, которая по введённому пользователем номеру дня недели выводит на экран

его название.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Лебединская Анастасия.

#include <iostream>

using namespace std;

int main()

{

int number;

 

cout << "Input number: ";

cin >> number;

 

switch(number)

{

 case 1:

  cout << "Monday";

  break;

 case 2:

  cout << "Tuesday";

  break;

 case 3:

  cout << "Wednesday";

  break;

 case 4:

  cout << "Thursday";

  break;

 case 5:

  cout << "Friday";

  break;

 case 6:

  cout << "Saturday";

  break;

 case 7:

  cout << "Sunday";

  break;

 default:

  cout << "Input error!";

  return 1;

}

return 0;

}


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи вам понадобится простая программа на C++. Вот пример кода, который выполняет указанную задачу:

cpp
#include <iostream> using namespace std; int main() { int dayNumber; // Выводим приветствие и просим пользователя ввести номер дня недели cout << "Введите номер дня недели (от 1 до 7): "; cin >> dayNumber; // Проверяем введенное значение и выводим соответствующее название дня недели switch (dayNumber) { case 1: cout << "Понедельник" << endl; break; case 2: cout << "Вторник" << endl; break; case 3: cout << "Среда" << endl; break; case 4: cout << "Четверг" << endl; break; case 5: cout << "Пятница" << endl; break; case 6: cout << "Суббота" << endl; break; case 7: cout << "Воскресенье" << endl; break; default: cout << "Некорректный номер дня недели. Введите число от 1 до 7." << endl; } return 0; }

Когда вы запустите эту программу, она запросит у пользователя ввести номер дня недели от 1 до 7. Затем она выведет соответствующее название дня недели на экран. Если пользователь введет некорректное значение, программа выдаст сообщение об ошибке.

Примеры входных данных и соответствующих выводов:

scss
Введите номер дня недели (от 1 до 7): 3 Среда
scss
Введите номер дня недели (от 1 до 7): 8 Некорректный номер дня недели. Введите число от 1 до 7.
0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос