Вопрос задан 27.07.2023 в 01:52.
Предмет Информатика.
Спрашивает Шестаков Павлик.
Написать программу подсчитывающую кол-во чётных и нечётных цифр в числе. Только на Паскале.
Ответы на вопрос
Отвечает Ефремов Роман.
PascalABC.NET 3.4.2, сборка 1837 от 11.10.2018
begin
var s := ReadInteger.ToString;
var Четных := s.Where(c -> '02468'.Contains(c)).Count;
var Нечетных := s.Where(c -> '13579'.Contains(c)).Count;
Println('Четных', Четных, 'нечетных', Нечетных);
end.

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Pascal для подсчета количества четных и нечетных цифр в числе:
pascalprogram CountEvenAndOddDigits; var num, digit, evenCount, oddCount: Integer; begin // Инициализируем счетчики четных и нечетных цифр evenCount := 0; oddCount := 0; // Вводим число с клавиатуры Write('Введите число: '); Readln(num); // Перебираем цифры числа while num > 0 do begin // Получаем последнюю цифру числа digit := num mod 10; // Проверяем, четное ли это число if digit mod 2 = 0 then Inc(evenCount) else Inc(oddCount); // Уменьшаем число на один разряд num := num div 10; end; // Выводим результаты Writeln('Количество четных цифр: ', evenCount); Writeln('Количество нечетных цифр: ', oddCount); end.
Программа запрашивает у пользователя ввод числа и затем перебирает его цифры, проверяя, является ли каждая цифра четной или нечетной. Затем выводит количество четных и нечетных цифр на экран.
Похожие вопросы
Информатика 82
Информатика 99
Информатика 38
Информатика 96
Информатика 50
Информатика 15
Информатика 24
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
