Вопрос задан 26.07.2023 в 20:16.
Предмет Информатика.
Спрашивает Крюкова Анна.
Мне нужна помощь: В Фрее паскаль Рассмотрим массив T [1..n] целых чисел, где n <= 20.
Напишите программу, используя процедуру, которая будет отображать положительные элементы этого массива.Мне нужно под этот модель :этот програм считает сумму. type tab=array[1..10] of integer; var a:tab; i,n:integer; s:real; procedure suma(var x:tab; n:integer; var sum:real); var i:integer; begin sum:=0; for i:=1 to n do sum:=sum+x[i]; end; begin{main} write('n='); readln(n); write('dati elementele tabloului:'); for i:=1 to n do readln(a[i]); suma(a,n,s); write('s=',s:7:2); end. Спасибо заранее.Ответы на вопрос
Отвечает Чупина Екатерина.
Ну как-то так, в фрипаскале работает

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения задачи отображения положительных элементов массива вам не понадобится процедура suma. Вам нужно просто добавить процедуру, которая будет отображать положительные элементы. Вот модифицированный код:
pascaltype tab = array[1..20] of integer; var a: tab; i, n: integer; procedure displayPositiveElements(var x: tab; n: integer); var i: integer; begin writeln('Положительные элементы массива:'); for i := 1 to n do begin if x[i] > 0 then writeln(x[i]); end; end; begin {main} write('n='); readln(n); write('Введите элементы массива:'); for i := 1 to n do readln(a[i]); displayPositiveElements(a, n); end.
Обратите внимание, что я изменил размер массива tab на 20, чтобы учесть условие задачи n <= 20. Процедура displayPositiveElements проходит по массиву x и выводит все положительные элементы. Это позволит вам отобразить положительные элементы массива T [1..n] целых чисел.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 18
Информатика 34
Информатика 19
Информатика 26
Информатика 20
Информатика 33
Информатика 31
Информатика 21
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
