Написать программу на с++, используя функции. Найти наименьшее общее кратное четырех заданных
натуральных чисел.Ответы на вопрос
#include <iostream>
#define _ std::
int NOD(int a, int b){
return (a == 0) ? b : NOD(b%a, a);
}
int NOK(int a, int b) {
return (a*b) / NOD(a, b);
}
int main() {
int a, b, c, d;
_ cin >> a >> b >> c >> d;
_ cout << NOK(a, NOK(b, NOK(c, d))) << _ endl;
}
Для нахождения наименьшего общего кратного (НОК) четырех заданных натуральных чисел, можно использовать алгоритм нахождения НОК через нахождение наибольшего общего делителя (НОД). Сначала найдем НОД двух чисел, а затем используем его для вычисления НОК. Воспользуемся алгоритмом Евклида для нахождения НОД.
Вот программа на C++, которая решает эту задачу, используя функции:
cpp#include <iostream>
// Функция для нахождения наибольшего общего делителя (НОД) двух чисел
int gcd(int a, int b) {
while (b != 0) {
int temp = b;
b = a % b;
a = temp;
}
return a;
}
// Функция для нахождения наименьшего общего кратного (НОК) двух чисел
int lcm(int a, int b) {
return (a * b) / gcd(a, b);
}
// Функция для нахождения НОК четырех чисел
int lcmFourNumbers(int a, int b, int c, int d) {
int result1 = lcm(a, b);
int result2 = lcm(c, d);
return lcm(result1, result2);
}
int main() {
int num1, num2, num3, num4;
std::cout << "Введите четыре натуральных числа: ";
std::cin >> num1 >> num2 >> num3 >> num4;
int result = lcmFourNumbers(num1, num2, num3, num4);
std::cout << "Наименьшее общее кратное четырех чисел: " << result << std::endl;
return 0;
}
Пользователь должен ввести четыре натуральных числа, а программа найдет и выведет наименьшее общее кратное этих чисел.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
