Вопрос задан 26.07.2023 в 03:08.
Предмет Информатика.
Спрашивает Дирда Миша.
ПАСКАЛЬ Напишите программу, которая заполняет массив из N элементов в обратном порядке
последовательными натуральными числами, начиная с последнего элемента, который должен быть равен X . Входные данные Входная строка содержит два целых числа: начальное значение X и размер массива N , разделённые пробелом. Гарантируется, что 0 < N ≤ 10000 . Выходные данные Программа должна вывести содержимое массива: убывающую последовательность из N последовательных натуральных чисел; последний элемент должен быть равен X . Примеры входные данные 6 4 выходные данные 9 8 7 6Ответы на вопрос
Отвечает Дроздюк Анастасия.
var a:array[1..10000] of integer;
x,n,i: integer;
begin
readln(x,n);
for i:=1 to n do a[i]:=x+n-i;
for i:=1 to n do write(a[i],' ');
writeln;
end.
Пример:
6 4
9 8 7 6
Отвечает Смольников Влад.
PascalABC.NET 3.4.2, сборка 1864 от 11.11.2018
Внимание! Если программа не работает, обновите версию!
begin
var (x, n) := ReadInteger2;
var a := ArrGen(n, n + x - 1, t -> t - 1);
a.Println
end.
6 4
9 8 7 6
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи на языке Паскаль, нужно объявить массив и заполнить его значениями в обратном порядке от X до X-N+1. Вот программа, решающая данную задачу:
pascalprogram ReverseArray; var X, N, i: Integer; arr: array of Integer; begin // Ввод данных Readln(X, N); // Инициализация длины массива SetLength(arr, N); // Заполнение массива в обратном порядке for i := 0 to N - 1 do arr[N - 1 - i] := X - i; // Вывод содержимого массива for i := 0 to N - 1 do Write(arr[i], ' '); end.
Пример входных данных:
6 4
Пример вывода:
9 8 7 6
Программа считывает значения X и N, затем создает массив с размером N и заполняет его последовательными натуральными числами, начиная с X и уменьшая на 1 на каждой итерации, пока не заполнит весь массив. Затем программа выводит содержимое массива.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
