Вопрос задан 25.07.2023 в 22:52.
Предмет Информатика.
Спрашивает Дроздова Аня.
Составить программу вывода на экран всех четных элементов массива со значениями -10 от -10 (Паскаль)
Ответы на вопрос
Отвечает Такуми Юра.
PascalABC.NET 3.4.2, сборка 1863 от 10.11.2018
Внимание! Если программа не работает, обновите версию!
begin
var a := ArrRandom(ReadInteger('n='), -10, 10);
a.Println;
a.Where(t -> t.IsEven).Println
end.
n= 15
-9 2 -2 7 -6 6 -4 -1 2 0 -9 8 -3 -6 -6
2 -2 -6 6 -4 2 0 8 -6 -6
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи в Паскале, нужно создать массив, заполнить его четными элементами от -10 до 10 и вывести на экран только те элементы, которые удовлетворяют условию (четные). Вот программа для этого:
pascalprogram OutputEvenElements; const Size = 11; // Размер массива (от -10 до 10 включительно) var arr: array[1..Size] of Integer; i: Integer; begin // Заполнение массива четными элементами от -10 до 10 for i := 1 to Size do begin arr[i] := -10 + (i - 1) * 2; end; // Вывод четных элементов на экран writeln('Четные элементы массива:'); for i := 1 to Size do begin if arr[i] mod 2 = 0 then writeln(arr[i]); end; end.
Обратите внимание, что массив состоит из 11 элементов, так как нужно включить в него значение -10 и 10. Затем мы выводим только четные элементы с помощью проверки условия arr[i] mod 2 = 0. Если остаток от деления элемента на 2 равен 0, это означает, что элемент четный, и мы выводим его на экран.
Похожие вопросы
Информатика 24
Информатика 328
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
