Вопрос задан 25.07.2023 в 18:20.
Предмет Информатика.
Спрашивает Лис Даша.
Напишите программу для решения задачи : задано трехзначное положительное число. есть ли среди
цифр числа цифра 7? если есть, на каком месте стоит? паскальОтветы на вопрос
Отвечает Пусташинский Владислав.
begin
ReadInteger('num =').ToString.ToCharArray
.IndexesOf(x -> x = '7').Select(x -> x + 1).Println;
end.

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения данной задачи в Pascal, нужно получить от пользователя трехзначное положительное число, затем проверить наличие цифры 7 среди его цифр и определить, на каком месте она стоит. Вот пример программы:
pascalprogram FindDigitSeven; var number, digit, position: Integer; found: Boolean; begin found := False; // Ввод трехзначного числа repeat Write('Введите трехзначное положительное число: '); ReadLn(number); until (number >= 100) and (number <= 999); // Поиск цифры 7 position := 0; while (number > 0) and (not found) do begin position := position + 1; digit := number mod 10; if digit = 7 then found := True else number := number div 10; end; // Вывод результата if found then WriteLn('Цифра 7 находится на ', position, ' месте в числе.') else WriteLn('Цифра 7 не найдена в числе.'); end.
Эта программа запрашивает у пользователя трехзначное число, затем проверяет каждую цифру числа, чтобы определить, есть ли среди них цифра 7. Если цифра 7 найдена, программа сообщит, на каком месте она находится (считая справа налево). Если цифра 7 не обнаружена, программа также сообщит об этом.
Похожие вопросы
Информатика 80
Информатика 95
Информатика 64
Информатика 47
Информатика 44
Информатика 353
Информатика 49
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 265
Информатика 25
Информатика 33
Информатика 16
Информатика 10
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
