Вопрос задан 25.07.2023 в 09:36. Предмет Информатика. Спрашивает Агеенко Валерия.

На с++ с циклом white На вход программы подается 10 чисел. Выведите в столбик для каждого из них

число, равное удвоенному квадрату первоначального числа.Формат входных данныхВ единственной строке через пробел вводятся 10 целых чисел, по модулю не превосходящих 1000.Формат выходных данныхНеобходимо вывести 10 строк, в каждой из которых будет по одному числу — результат преобразования исходных чисел.Примерывходные данные выходные данные1 10 2 4 2 5 3 6 101 112200832850187220402242
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кокарев Денис.

Решение с массивами

#include <bits/stdc++.h>

using namespace std;

int main() {

   int a[10];

   int i = 0;

   while (i < 10) {

     cin >> a[i];

     ++i;

   }

   i = 0;

   while (i < 10) {

     cout << (2 * a[i] * a[i]) << endl;

     ++i;

   }

   return 0;

}


Решение без массивов (онлайн-вывод)

#include <bits/stdc++.h>

using namespace std;

int main() {

   int x;

   int i = 0;

   while (i < 10) {

     cin >> x;

     cout << (2 * x * x) << endl;

     ++i;

   }

   return 0;

}


0 0
Отвечает Козакова Мария.
  • Прикреплена фотография с кодом, тест и сам код
  • Открывать любым текстовым редактором



0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи на C++, вы можете использовать цикл for для считывания входных данных и вывода результата. Вот пример программы:

cpp
#include <iostream> int main() { int numbers[10]; // Вводим 10 чисел в массив for (int i = 0; i < 10; ++i) { std::cin >> numbers[i]; } // Выводим результат преобразования для каждого числа for (int i = 0; i < 10; ++i) { int result = 2 * numbers[i] * numbers[i]; std::cout << result << std::endl; } return 0; }

Программа считывает 10 чисел в массив numbers, а затем вычисляет результат преобразования для каждого числа и выводит его на отдельной строке. В данном случае, результат преобразования — удвоенное значение квадрата числа.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос