Вопрос задан 25.07.2023 в 07:49. Предмет Информатика. Спрашивает Крапицкая Валерия.

Python 3 HELP Написать 3 программы 1. Известно, что 1 дюйм равен 2.54 см. Разработать приложение,

переводящие дюймы в сантиметры и наоборот. (перевод оформить в функции) Диалог с пользователем реализовать через систему меню. 2. Написать программу, которая вычисляет сумму и произведение всех положительных четных чисел из введенных шести. 3.Напишите функцию Procent, которая возвращает процент от полученного в качестве аргумента числа.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Андрианов Максим.

def translation_of_lengths(n, m):

   inch = 2.54

   if m == 'duim':

       print("{} inch = {}cm ".format(n, (n * inch)))

   if m == 'cm':

       print("{} cm = {} inch ".format(n, (round(n / inch, 2))))

translation_of_lengths(5, 'duim')

translation_of_lengths(120, 'cm')

def even_numbers(s):

   s_mas = s.split()

   if len(s_mas) != 6:

       print("\tYou have entered not 6 numbers!")

       print(s_mas)

   else:

       x = sum(int(i) for i in s_mas if int(i) >= 0 if int(i) % 2 == 0)

       print("The sum of even numbers {}".format(x))

a = input("Numbers: ")

even_numbers(a)

def procent(x, y):

   print('{}% from the number {} = {}'.format(x, y, (x / 100) * y))

procent(55, 120)


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для выполнения этих задач, давайте начнем с написания каждой программы по порядку.

  1. Программа для перевода дюймов в сантиметры и наоборот:
python
def inches_to_cm(inches): return inches * 2.54 def cm_to_inches(cm): return cm / 2.54 def main(): while True: print("Меню:") print("1. Перевести дюймы в сантиметры") print("2. Перевести сантиметры в дюймы") print("3. Выйти") choice = int(input("Выберите опцию (1/2/3): ")) if choice == 1: inches = float(input("Введите количество дюймов: ")) cm = inches_to_cm(inches) print(f"{inches} дюймов = {cm} см") elif choice == 2: cm = float(input("Введите количество сантиметров: ")) inches = cm_to_inches(cm) print(f"{cm} см = {inches} дюймов") elif choice == 3: break else: print("Неправильный выбор. Попробуйте снова.") if __name__ == "__main__": main()
  1. Программа для вычисления суммы и произведения всех положительных четных чисел из шести введенных чисел:
python
def main(): numbers = [] for i in range(6): num = int(input(f"Введите число {i+1}: ")) numbers.append(num) positive_even_numbers = [num for num in numbers if num > 0 and num % 2 == 0] if not positive_even_numbers: print("Введены некорректные числа или нет положительных четных чисел.") else: sum_positive_even = sum(positive_even_numbers) product_positive_even = 1 for num in positive_even_numbers: product_positive_even *= num print("Сумма положительных четных чисел:", sum_positive_even) print("Произведение положительных четных чисел:", product_positive_even) if __name__ == "__main__": main()
  1. Программа с функцией Procent, которая возвращает процент от полученного в качестве аргумента числа:
python
def Procent(number, percentage): return number * percentage / 100 def main(): number = float(input("Введите число: ")) percentage = float(input("Введите процент: ")) result = Procent(number, percentage) print(f"{percentage}% от числа {number} равно {result}") if __name__ == "__main__": main()

Теперь у вас есть три программы, каждая соответствует вашим запросам и реализована в виде функций. Вы можете запустить их по отдельности и использовать по своему усмотрению.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос